[Supporto richiesto] Aiuto Microdisplacement

Stai vedendo 15 articoli - dal 1 a 15 (di 15 totali)
  • Autore
    Articoli
  • #495711

    IgnisRaptorem
    Partecipante
    • Blenderista
    • Post sul forum 17

    Ragazzi ho bisogno di aiuto, non riesco ad ottenere quello che é riportato nel seguente link: http://blenderartists.org/forum/showthread.php?396697-Cycles-new-microdisplacement-build-and-testing
    qualcuno potrebbe aiutarmi magari facendomi una piccola guida o semplicemente spiegandomi come funziona? ve ne sarei grato.
    P.s. Ho fatto svariati tentativi ma il mio inglese non è molto ferrato, magari qualcuno con un po’ di esperienza in più ^_^


    The abyss walker
    0
    #495783

    andcamp
    Moderatore
    • Veterano Platino
    • ★★★★★★
    • Post sul forum 5481
    • Blender.it Staff
    • Associato Blender Italia

    è ancora una build non ufficiale però, se non ricordo male


    0
    #495785

    Harvester
    Moderatore
    • Veterano Bronzo
    • ★★★
    • Post sul forum 2476
    • Blender.it Staff
    • Associato Blender Italia

    Scarica una build di sviluppo per il tuo sistema operativo dal sito https://builder.blender.org/download/, scompatta il contenuto ed avvia Blender. Se lo ritieni opportuno configura le User Preferences in base alle tue preferenze o necessità (per esempio, percorsi, impostazioni eccetera).

    Nel pannello Render commuta su Experimental il Feature Set.

    Quindi aggiungi un piano come esempio nella scena, non suddiviso, e nel relativo pannello Object Data sotto la voce Displacement attiva True e Catmull-Clark (o linear), lascia pure il Dicing Rate a 1.0 (minore è questo valore è maggiore sarà il livello di suddivisione del piano in fase di visualizzazione e rendering).

    Ritorna nel pannello Rendering dove nella sezione Geometry potrai impostare il fattore di suddivisione per la visualizzazione a video (Rendered View) e per il rendering vero e proprio, separatamente (per esempio, 1 per il rendering ed 8 per la preview).

    A questo punto non resta che aggiungere il materiale al piano ed incorporare una texture da collegare all’ingresso Displacement del nodo Output.

    Riprova e vedrai che funziona.

     

     

     

    1+
    #496001

    Admin blender.it
    Amministratore del forum
      Post sul forum 1270

    Ciao Ignis,

    Dacci conferma che sei riuscito. Fai poi vedere cosa hai realizzato 😉


    0
    #496007

    IgnisRaptorem
    Partecipante
    • Blenderista
    • Post sul forum 17

    beh c’è poco da far vedere, purtroppo non supporta la mappatura di tipo UV quindi non mi è stato molto utile


    The abyss walker
    0
    #534327

    Hullo
    Partecipante
    • Blenderista
    • Post sul forum 354

    Ho provato a seguire la guida di Harvester ma nemmeno io ne vengo fuori.Ho visto dei tutorial dove veniva applicata una mappa displacement a dei piani senza suddivisioni con risultati più che soddisfacenti.

    Non è che per caso la funzione displacement true adesso è stata spostata nella pare dedicata alle texture,io nel pannello indicao da Harvester non la trovo…

    0
    #534329

    Harvester
    Moderatore
    • Veterano Bronzo
    • ★★★
    • Post sul forum 2476
    • Blender.it Staff
    • Associato Blender Italia

    Siete certi di aver attivato tutte le opzioni richieste per il suo funzionamento? Questa è una schermata riepilogativa:

     

     

    0
    #534332

    Akenaton
    Partecipante
    • Blenderista
    • Post sul forum 241
    • Associato Blender Italia

    Per il materiale io uso both invece che true, ma sostanzialmente cambia poco…se nn attivi tutto quello che ti ha detto Harvester il microdisplacement non funziona, o per lo meno non come vorresti tu

     

    0
    #534333

    Hullo
    Partecipante
    • Blenderista
    • Post sul forum 354

    Grazie per le risposte, ho ricontrollato ed effettivamente ho tutto attivato, l’unica differenza è che ho mantenuto 8 suddivisioni in render preview.Ma nonostante tutto il risultato è lontano anni luce da quello postato da Harvester.

    Quello che non capisco è che il tipo del tutorial non usa nemmeno subdivision surface….boh.

     

    Se può interessare il tutorial è questo https://www.youtube.com/watch?v=Ma2ANjDzjCM&t=404s

    0
    #534334

    Harvester
    Moderatore
    • Veterano Bronzo
    • ★★★
    • Post sul forum 2476
    • Blender.it Staff
    • Associato Blender Italia

    Hai inserito il link alla prima parte invece della seconda dove illustra il procedimento. Ti sei probabilmente distratto perchè qui è dove aggiunge il modificatore Subdivision Surface al modello.

    0
    #534340

    Hullo
    Partecipante
    • Blenderista
    • Post sul forum 354

    Su tre volte che me lo sono riguardato l’ho notato solo ora…non c’è male.Grazie per l’aiuto, riprovo ma non credo di riuscire….

    0
    #534440

    Hullo
    Partecipante
    • Blenderista
    • Post sul forum 354

    Ho riprovato ed effettivamente non avevo attivato nemmeno l’optimal display nel subsurf nè tantomeno utilizzato i vari math dopo la texture.Il risultato ora è soddisfacente,grazie ancora harvester.Per quanto riguarda la mappa displacement è meglio usare un file .exr (facendo il bake con camera data) oppure basta anche un tiff fatto con gimp o photoshop?

    0
    #534442

    Harvester
    Moderatore
    • Veterano Bronzo
    • ★★★
    • Post sul forum 2476
    • Blender.it Staff
    • Associato Blender Italia

    Se puoi usa immagini a 32bit per il displacement. Non è necessario che siano di grandi dimensioni (x,y) perchè quello che conta è la profondità dei bit. Puoi anche creare le tue texture per il displacement in Blender (in rete trovi diversi tutorial).

    0
    #536628

    Hullo
    Partecipante
    • Blenderista
    • Post sul forum 354

    Torno nuovamente sull’argomento, a me tanto caro.

    Sto modellando un pozzo,forma molto semplice, e voglio che una parte sia con i mattoni a vista; ho mixato le texture cemento e mattoni, creata una maschera ad hoc con vertex paint e color ramp e unito il tutto in microdisp….e qui ti volevo.

    Perchè in anteprima (foto sotto) il risultato è proprio come speravo che fosse

    mentre nel render

    viene fuori questa roba inguardabile……perchè?

    Cìè qualcuno che mi sa aiutare di nuovo?

    Grazie in anticipo.

    0
    #536632

    Hullo
    Partecipante
    • Blenderista
    • Post sul forum 354

    Ho risolto…..ma mi è venuto un altro dubbio, casomai apro un 3ad apposito, ammessso che già non ci sia…..cerco.

    0
Stai vedendo 15 articoli - dal 1 a 15 (di 15 totali)

Devi essere loggato per rispondere a questa discussione.