[Risolto] Aiuto texture con Alpha tramite UV

Blender.it | Supporto Utenti | Supporto Materiali e texture | Aiuto texture con Alpha tramite UV

Stai vedendo 16 articoli - dal 1 a 16 (di 16 totali)
  • Autore
    Articoli
  • #521902

    CyberJabba
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 402
    • Associato Blender Italia

    Salve ragazzi,

    ho bisogno del vostro aiuto. Sto provando ad applicare una texture tramite UV su un oggetto che presenta delle trasparente, praticamente un’etichetta. Il problema è che nonostante abbia abilitato sia la voce Face Textures che Face Textures Alpha, renderizzando la trasparenza appare nera. Come immagine ho usato una PNG fatta in Gimp.

    Consigli?

    Grazie.
    CJ


    CJ
    #521909

    Harvester
    Partecipante
    • Veterano Bronzo
    • ★★★
    • Post sul Forum 2663
    • Blender.it Staff
    • Associato Blender Italia
    • Moderatore Forum

    Non farei in quel modo con Blender Render ma così:

    #521910

    CyberJabba
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 402
    • Associato Blender Italia

    Ciao Harvester ti ringrazio,

    ma quindi mi dici di non usare l’UV mapping oppure che devo cmq creare una texture anche se già mappata nell’UV Editor?

    CJ


    CJ
    #521911

    Harvester
    Partecipante
    • Veterano Bronzo
    • ★★★
    • Post sul Forum 2663
    • Blender.it Staff
    • Associato Blender Italia
    • Moderatore Forum

    Nel mio esempio sono partito da un cilindro, ho aggiunto qualche loop cut in verticale, ho quindi selezionato una serie di facce che ho duplicato e separato per usarle come etichetta, quindi ho eseguito l’UV Unwrap dell’etichetta a cui ho assegnato un materiale ed all’interno di quest’ultimo ho creato una texture per l’immagine dell’etichetta. Non vorrei diventare pedante quindi spero sia chiaro il processo. Il resto è questione di impostare la trasparenza per il materiale etichetta e settare correttamente l’influenza della texture (ai canali colore e trasparenza). Fai qualche prova per prendere dimestichezza con il procedimento.

    #521912

    Harvester
    Partecipante
    • Veterano Bronzo
    • ★★★
    • Post sul Forum 2663
    • Blender.it Staff
    • Associato Blender Italia
    • Moderatore Forum

    Il fatto che tu abbia mappato l’immagine nel UV Image editor non comporta automaticamente che sia visualizzata in fase di rendering poichè quello che ti sembra “mappato” a video in realtà vale solo per la vista 3D. Quindi, in sostanza, devi creare un materiale ed in esso aggiungere le texture che avrai ovviamente anche mappato. E’ più facile a farsi che a dirsi.

    Puoi anche non creare una etichetta come oggetto a sè stante ma assegnare due diversi materiali, uno alla bottiglia o quello che è ed uno alle facce che fungeranno da etichetta. In questo caso potrebbe rendersi necessario creare due mappe UV, una per la bottiglia (metti che vuoi aggiungere dettagli come graffi, impronte eccetera), e la seconda per la parte a cui assegnerai il materiale etichetta (occhio che dovrai specificare quale mappa UV usare nelle impostazioni delle texture).

    #521914

    CyberJabba
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 402
    • Associato Blender Italia

    Si praticamente quello che avevo fatto era stato assegnare un materiale all’oggetto e poi mappare etichetta dall’UV Editor solo sulle facce che mi interessavano. Tutto perfetto se non fosse che non riesco a far veder il canale alpha. Adesso ho provato a creare due materiali diversi e assegnarli alla bottigletta con le impostazioni da te consigliate ma il risultato è sempre lo stesso. Non vedo la trasparenza del canale alpha dell’immagine. Ti allego due screen per semplicità:

    CJ


    CJ
    #521915

    CyberJabba
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 402
    • Associato Blender Italia


    CJ
    #521916

    Harvester
    Partecipante
    • Veterano Bronzo
    • ★★★
    • Post sul Forum 2663
    • Blender.it Staff
    • Associato Blender Italia
    • Moderatore Forum

    Il problema è nelle impostazioni della texture poiché non hai spuntato anche il canale Alpha (sotto Color). Inoltre, se usi la mappatura UV devi impostare Flat e non Tube come tipo di proiezione (anche se probabilmente non noterai grande differenza). Riprova.

    #521917

    CyberJabba
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 402
    • Associato Blender Italia

    Provato, niente…

     

    non capisco…


    CJ
    #521924

    CyberJabba
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 402
    • Associato Blender Italia

    Ho provato a replicare la cosa solamente con un piano ed ha funzionato al primo colpo (!)

    Ho attivato solamente tre opzioni,  Face Textures, Face Textures Alpha e Transparency, tutti e tre sul materiale…

    Provo a rifare tutto da capo e vediamo che succede… 😉

    CJ


    CJ
    #521927

    CyberJabba
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 402
    • Associato Blender Italia

    Ho riprovato a fare la stessa cosa ma questa volta mappando solamente alcune facce del piano e il problema si è ripresentato… dov’è che sbaglio? Anche perchè ho problemi solamente con il canale alpha… è giusto così? Sbaglio io?

    Consigli?

    CJ


    CJ
    #521931

    Harvester
    Partecipante
    • Veterano Bronzo
    • ★★★
    • Post sul Forum 2663
    • Blender.it Staff
    • Associato Blender Italia
    • Moderatore Forum

    Seleziona prima il materiale dell’etichetta quindi clicca sull’icona alla sua destra ed entri così nel pannello delle texture associate al materiale. E’ qui che devi creare una nuova texture, assegnandovi l’immagine dell’etichetta ed impostandone mappatura ed influenza. Posto questa nuova immagine dove evidenzio la struttura ad albero dell’oggetto etichetta con materiale e relativa texture immagine.

    #521934

    CyberJabba
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 402
    • Associato Blender Italia

    Questo è quello che ho attualmente:

    Mi sembra di lavorare sulla mesh giusta… o sbaglio? Mammamia sto impazzendo ^^

     

    CJ

     


    CJ
    #521935

    Harvester
    Partecipante
    • Veterano Bronzo
    • ★★★
    • Post sul Forum 2663
    • Blender.it Staff
    • Associato Blender Italia
    • Moderatore Forum

    Dalla tua ultima schermata devi cambiare il tipo di proiezione da Tube a Flat, inoltre devi attivare la trasparenza per il relativo materiale.

    #522051

    CyberJabba
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 402
    • Associato Blender Italia

    Grazie Harvester alla fine ci sono riuscito! Solo che ho dovuto disattivare nel menu influence (texture) la voce alpha e nel materiale la voce transparency perchè con quelle attive veniva tutto nero. Devo studiare un altro pò…

    Grazie di tutto!

    CJ


    CJ
    #522179

    Harvester
    Partecipante
    • Veterano Bronzo
    • ★★★
    • Post sul Forum 2663
    • Blender.it Staff
    • Associato Blender Italia
    • Moderatore Forum

    Certo, prenditi il tempo che ti serve e nel frattempo se ritieni che il tuo “problema” sia risolto imposta la discussione su Risolto nel menu che trovi in alto.

Stai vedendo 16 articoli - dal 1 a 16 (di 16 totali)

Devi essere loggato per rispondere a questa discussione.