• Questo topic ha 13 risposte, 7 partecipanti ed è stato aggiornato l'ultima volta 3 mesi fa da Nico.
Stai visualizzando 14 post - dal 1 a 14 (di 14 totali)
  • Autore
    Post
  • #510263

    Salve a tutti,

    ho aggiornato il mio sistema per motivi di ottimizzare la performanza e ho approfittato per eseguire dei test sulle schede video.

    Nel sistema precedente (con due GTX770) ho avuto la necessità di riattivare dal BIOS la scheda video integrata (Intel) per collegare i due monitor. Questa operazione è stata necessaria perché durante il rendering in doppia GPU le schede video, totalmente occupate nel processo, rendevano il PC inutilizzabile per altre operazioni video )anche un semplice spostamento di una cartella a video). Il problema è stato cos’ risolto e consiglio a tutti questa semplice operazione.

    Nell’aggiornare il sistema (Processore Intel i7 3430K 6 core – 12 logici; 32 GB RAM 2133; MB MSI; 2 GPU Nvidia GTX770 4 GB RAM; HD SSD; 5 ventole; case e alimentatore Corsair), con stupore mi sono accorto che la nuova MB non ha una scheda video integrata.

    Nel collegare una vecchia Nvidia GT545 solo per i monitor, con sorpresa mi sono accorto che non era possibile, nel Compute Device di Blender impostare come GPU le sole GTX770. Le opzioni erano: GTX770 (1); GTX770 (2); GT545; tutte e tre insieme.

    Ora, la GT454 ha solo 144 Cuda Core e 3 GB di RAM, mentre le GTX770 circa 1500 Cuda Core cadauna e 4 GB di RAM. Ho fatto un test di rendering con una scena pesante (sistema particellare spinto) con le 3 schede e c’è stato l’atteso e inevitabile Cuda Error.

    La soluzione è stata semplice: nel pannello di controllo Nvidia, è stato sufficiente impostare le due GTX770 come Cuda GPU nel pannello “Gestisci le impostazioni 3D”. In questo modo la GT545 è stata disattivata dal calcolo di rendering 3D in tutto il PC.

    DI conseguenza anche il Compute Device di Blender nella User Preferences, mi ha permesso la scelta delle due GTX770 separatamente e di entrambe insieme, risolvendomi il problema.

    L’ultimo test che ho voluto fare è stato quello di provare a collegare in SLI le due schede.

    Con i due monitor connessi alla GT545 (fuori dal calcolo GPU) e le due GTX770 a calcolare, ho lanciato una scena da renderizzare a 1920×1080 a 2000 samples. Questi sono stati i risultati:

    1. una sola GTX770 impostata in Blender e connesse entrambe in SLI, rendering completato in 4 minuti, 57 secondi e 53 decimi;
    2. con le due GTX770 connesse entrambe in SLI ed entrambe selezionate in Blender, rendering completato in 2 minuti, 33 secondi e 30 decimi;
    3. con le due GTX770 NON in SLI ed entrambe selezionate in Blender, rendering completato in 2 minuti, 33 secondi e 99 decimi.

    Sembrerebbe confermare che lo SLI probabilmente non viene contemplato da Blender ai fini del calcolo e che le due schede funzionano in ogni caso in parallelo.

    Che ne pensate? Avete fatto qualche prova analoga?

    Riccardo Cosenza
    Membro
    • Blenderista
    • Post sul Forum 153
    @astrosofia
    #510271

    interessante, ma non posso aiutarti al momento perchè ho da poco comprato una ati, dopo ho pensato di cominciare con blender e mi sà che non è compatibile e devo renderizzare con la cpu

    #510275

    Infatti la tecnologia cuda core di Nvidia è maggiormente indicata per il motore di rendering Cycles.

    #510279

    anch’io ho da poco ho aggiornato il sistema e anch’io mi ritrovo in una situazione simile: due nvidia e motherboard senza scheda video integrata. non posso fare altro per problemi di spazio nel case. interessante conferma la questione dello SLI (avevo letto che blender non lo gestisce, per cui non avevo nemmeno provato a collegare le schede)


    architetto freelance – CG artist
    #510309

    Direi che una scheda di controllo monitor fuori dal calcolo GPU sia fondamentale.

    mitch37
    Membro
    • Blenderista
    • Post sul Forum 17
    @michelegatta
    #510337

    Io uso due schede diverse (gtx 580 e gtx 750 ti) quindi non posso dirti nulla sullo sli, interessante sarebbe provare se il limite di RAM usata è sempre i 4 GB o se con lo SLI si sommano. Le schede in genere lavorano separate dividendosi i tasselli del render… un tassello per scheda per volta ( 2 schede , due tasselli ), è uguale con lo SLI?

    #510403

    E’ come dici tu. Dai test che ho fatto, la RAM non si somma neanche in SLI. Ciò significa che si tratta esclusivamente di due metodi diversi di lettura (in serie, SLI, o in parallelo, no SLI).

    Con la SLI Blender non cambia impostazioni, in pratica non contempla questa tecnica.

    I software che gestiscono questo collegamento dovrebbero una sola scheda che gestisce le altre in cascata.

    crazypainter
    Partecipante
    @crazypainter
    #518912

    Buon giorno Andrea,
    ho recentemente acquistato un pc con due gtx 1080 8 Gb in SLI ma non riesco ad utilizzarle in coppia su Blender Cycles; quando accedo al pannello di controllo, nella sezione CUDA, vedo le due schede distinte – NVIDIA GTX 1080 ma non ho la voce NVIDIA GTX 1080 (x2).
    Ho provato a disabilitare lo SLI e verificare l’opzione CUDA dal pannello NVIDIA ma niente da fare. L’unico dubbio che ho è che non ho riavviato il pc quando ho disattivato lo SLI. Hai suggerimenti?

    Grazie

    #519957

    Leva SLI. Non lo vede proprio.

    Dal driver Nvidia dovresti attivare le due schede per il rendering. Poi vai in Blender in User Preferences e imposta System come CUDA con tutte e due le schede.

    Dovrebbe vederle senza problemi.

    Nico
    Partecipante
    @desegno
    #835658

    ciao ragazzi riapro la discussione per sapere una cosa.

    il mio pc ha due schede gtx 1070.

    uso prevalentemente in lightwave + octane senza nessun problema.

    Ora nell’apprendere blender vorrei tentare di abbandonare definitivamente motori di terze parti al fine di avere sempre un sw senza vincoli.

    noto però che il render in cycles resta per me un trilione di volte superiore ad evee ma è troppo lento, come se non utilizzasse le GPU.

    Posto degli screen perchè credo di aver settato tutto correttamente.

    non sono in SLI.

     

    Ogni consiglio resta graditissimo! 😉

     

     

    #835659

    prova a renderizzare in CPU e scoprirai cosa è veramente un render lento 😀


    architetto freelance – CG artist
    Nico
    Partecipante
    @desegno
    #835660

    :sleepy: :sleepy: 😀  sono solo 30 anni che lavoro in questo campo….ahahhaha non devo testare altro 😀 😀

    andcamp
    Moderatore
    @andcamp
    #835664

    hai provato togliendo la spunta al processore?

    Prova prima con una scheda, poi con due

     

    Utilizza strumenti che controllino l’utilizzo delle schede durante il rendering


    Nico
    Partecipante
    @desegno
    #835691

    Proverò, grazie :+1:

Stai visualizzando 14 post - dal 1 a 14 (di 14 totali)
  • Devi essere connesso per rispondere a questo topic.