Blender Italia forums Coding Tutorial Python Corso Python Alek Mugnozzo – Lezione 9

Stai visualizzando 20 post - dal 1 a 20 (di 20 totali)
  • Autore
    Post
  • #850036

    Il file della lezione 9, appena svolta: lezione-9


    Mugnozzo – creative open source technologies
    An-Br
    Partecipante
    @an-br
    #850037

    Grazie Alek

     


    Scegli un lavoro che ami, e non dovrai lavorare neppure un giorno in vita tua.

    (Confucio)

    fenix
    Partecipante
    @fenix64
    #850038

    mi sono perso l’ennesima lezione

    stando in tema che un tavolo e formato da piu elementi che potrebbero formare un gruppo se non vogliamo fonderlo

    ce un modo in piton per creare un gruppo come nelle precedenti versioni prima della nuova interfaccia si collegavano con ctrl g e si colorava in verde per far capire che era un gruppo grazie

     

    #850049

    Dalla 2.8 i layer e i gruppi sono stati sostituiti dalle collezioni.

    Se vuoi raggruppare le parti di un tavolo conviene metterli in una collezione (come abbiamo fatto in uno dei primi script che generavano il tavolino).

    Se si tratta di muoverli tutti insieme conviene imparentarli, se invece si vuole che siano raggruppati per poterli selezionare tutti insieme o per eseguire azioni massive basta la collezione.


    Mugnozzo – creative open source technologies
    An-Br
    Partecipante
    @an-br
    #850062

    Ciao Alek, ho un problema😔 per un paio di volte é andato tutto bene, dopo se lancio lo script della lezione 9, non ho errori, aggiungo il tavolino dal menú con F3 ma il ridupanel lo visualizza ma tutti i parametri sono disattivati, non posso modificarli e se ci clicco sparisce il ridupanel. Cosa ho combinato🥴🥴 grazie.


    Scegli un lavoro che ami, e non dovrai lavorare neppure un giorno in vita tua.

    (Confucio)

    SI50
    Partecipante
    @si50
    #850069

    nel  mio invece crea il tavolino ma non appare il redopanel ……..   🕵


    Live long and prosper 
    ProgHettoLab – Pierluigi Maria Bovi
    Partecipante
    @proghettolab
    #850086

    Alek ho scoperto l’errore… (che cavolata!) :cry:

    Invece di scrivere unit = ‘LENGTH’ ho scritto unit = ‘LENGHT’. :rage:

    A domani!


    pMB
    BruDem
    Partecipante
    @brunodemasi
    #850087

    Script per creare gambe intermedie

    https://pastebin.com/3vSF58YE

    Cambiando il valore della variabile “lun” inserisce delle gambe intermedie

    SI50
    Partecipante
    @si50
    #850105

    Visto che non riuscivo a trovare il problema , ho provato a ripartire da zero , però modificando lo script  per aggiungere una sedia: mesh.primitive_sedia_add

     

    https://pastebin.com/EWCCKqKe

     

     


    Live long and prosper 
    DIAPASON76
    Partecipante
    @maurola76
    #850110

    Giorno a tutti ! Ho provato a lanciare lo script di Alek e quello di SI50  non mi danno errori ma dal menu add non mi compare la voce sedia o tavolino mi sa che mi sono perso qualcosa ! è sufficente fare run dal text editor ?

     

    ProgHettoLab – Pierluigi Maria Bovi
    Partecipante
    @proghettolab
    #850111

    Non abbiamo affrontato l’inserimento della classe nei menù. Lo faremo sicuramente stasera. Usa F3 nell’editor 3d e scrivi Tavolino.


    pMB
    SI50
    Partecipante
    @si50
    #850127

    @maurola76 per il mio devi fare come ha detto Pierluigi , però dopo aver lanciato il file e pigiato F3 ,devi scrivere nella casella di ricerca  sedia


    Live long and prosper 
    fenix
    Partecipante
    @fenix64
    #850694

    purtroppo non basta la collection perche restano separati e anche imparentandoli non si muovono come gruppo devi cliccare quello giusto…

    io cercavo un gruppo proprio come insieme … tipo come ho gia detto il sistema precedente che collegava in un insieme gli elementi colorandoli di verde

     

    #850933

    Ciao a tutti e scusate la latitanza!

    Vado per ordine.


    @an-br
    : Stranissimo che siano disattivati. Hai provato a controllare se sei in Object/Edit Mode? Non riesco a replicare il problema.


    @si50
    : Non ti compare il Redo Panel: Hai eseguito lo script da menu o da console Python.


    @brunodemasi
    : Nel tuo script per le gambe intermedie l’unica cosa che noto è che a volte usi gli operatori in bpy.ops quando potresti lavorare con API di basso livello. Per il resto ok!


    @si50
    : Script sedia ok! Manca solo l’ultima riga, probabilmente sfuggita nel copia/incolla da Blender a PasteBin.


    @maurola76
    : Vedo che ti ha già risposto Pierluigi. :-)


    @fenix64
    : Un valido workaround potrebbe essere di imparentarli con la tavola (come abbiamo già fatto) e bloccare i gambi in modo che non possano essere selezionati.


    Mugnozzo – creative open source technologies
    An-Br
    Partecipante
    @an-br
    #850958

    Ciao Alek, solo per curiosità perchè ho risolto facendo un Load Factory Settings e ripristinando le mie preferenze. Però, adesso che tutto funziona bene, se “switcho” da Object a edit mod i parametri del ridupanel sono sempre attivi. Mistero, comunque l’importante è aver risolto. Grazie tante Alek.

     


    Scegli un lavoro che ami, e non dovrai lavorare neppure un giorno in vita tua.

    (Confucio)

    #850959

    Ciao! Intendi dire che crei il tavolino, poi vai in Edit e i parametri restano???


    Mugnozzo – creative open source technologies
    An-Br
    Partecipante
    @an-br
    #850995

    Ciao Alek, no, con un qualsiasi oggetto in scena vado in edit mode e creo il tavolino e appare il ridupanel. oppure creo il tavolino da Object e li, va bene, appare il ridupanel. In ambedue i casi, dopo il reset a factory settings, i parametri sono attivi e modificabili. Prima no.


    Scegli un lavoro che ami, e non dovrai lavorare neppure un giorno in vita tua.

    (Confucio)

    SI50
    Partecipante
    @si50
    #851115

    Grazie Alek

    Ho aggiunto su pastebin la riga mancante

    poi ho trovato l’errore, mancava la “s” di “bl_options”, strano però che non mi dava errore.

    buona serata


    Live long and prosper 
    #851185

    @an-br: Stranissimo. Comunque l’operatore funziona? Con i controlli della poll riesci ad escludere il comando in Edit Mode?


    @si50
    : Ottimo! Stasera lo trasformiamo in un add-on


    Mugnozzo – creative open source technologies
    An-Br
    Partecipante
    @an-br
    #851187

    Ciao Alek, si, è stranisimo ma, come ti dicevo, adesso dopo il reset a factory settings tutto funziona a dovere. Non so spiegarmi cosa fosse successo. Attendo stasera per trasformare in add-on lo script. Grazie. :D


    Scegli un lavoro che ami, e non dovrai lavorare neppure un giorno in vita tua.

    (Confucio)

Stai visualizzando 20 post - dal 1 a 20 (di 20 totali)
  • Devi essere connesso per rispondere a questo topic.