[Supporto richiesto] Crash durante render ad alta risoluzione

Blender.it | Supporto Utenti | Supporto Illuminazione, nodi e rendering | Crash durante render ad alta risoluzione

Stai vedendo 11 articoli - dal 1 a 11 (di 11 totali)
  • Autore
    Articoli
  • #539426

    SL31
    Partecipante
    • Blenderista
    • Post sul forum 6

    Essendo il mio primo post su questo sito, prima di passare al sodo vorrei approfittare dell’occasione per presentarmi: piacere, sono un modellatore ancora alle prime armi, non uso Blender da molto e magari il problema che sto per esporvi è una sciocchezza. Ma un aiutino sarebbe comunque gradito.

    Il punto è questo: ho bisogno di renderizzare una scena ad una risoluzione di 2480x3508px (un foglio A4 a 300dpi, per intenderci), ma neanche a metà del processo, Blender crasha improvvisamente. Ho provato anche passare dalla CPU alla GPU più volte. Prima che veniate a dirmi “Eh, ma se hai un PC scarso è ovvio che crasha”, fidatevi, non è affatto scarso, e la scena è leggerissima e fattibilissima da renderizzare senza problemi, o almeno dovrebbe esserlo. Guardate voi stessi:

    L’immagine è a bassa risoluzione, verrà sicuramente sgranata nel messaggio, e vi chiedo di non badare ai materiali e alle luci, che sistemerò poi. Guardate semplicemente il modello, giusto per rendervi conto di come questo problema mi sembra qualcosa di assurdo.

    Grazie in anticipo per eventuali risposte!

    0
    #539427

    TheAdryano99
    Partecipante
    • Blenderista
    • Post sul forum 22

    Beh potrebbe essere di tutto dati i sintomi assolutamente generici…. ma come crasha? Cioè il programma proprio scompare senza neanche dare un messaggio di errore?

    0
    #539428

    SL31
    Partecipante
    • Blenderista
    • Post sul forum 6

    Diciamo che all’inizio (intendo durante il render) lo schermo diventa completamente nero, poi appare la classica finestra di Windows “Blender ha smesso di funzionare” con il pulsante “chiudi” in basso. A quel punto, non posso fare altro che eseguire l’ordine. A volte addirittura non riesco più a chiuderlo, né con alt+F4 o terminando l’attività, e sono costretto a fare il logout.

    0
    #539431

    CyberJabba
    Partecipante
    • Blenderista
    • Post sul forum 329
    • Associato Blender Italia

    Benvenuto SL31,

    riuscire ad aiutarti così è difficile. La prima cosa che mi viene da chiederti è se a risoluzioni inferiori hai comunque lo stesso problema.

     

    CJ

    0
    #539432

    SL31
    Partecipante
    • Blenderista
    • Post sul forum 6

    Ciao CJ, in realtà no, finché effettuo il render per esempio in Full HD fila tutto liscio. A risoluzioni superiori, oltre a quella sopracitata, non ho provato.

    Comunque, l’unica impostazione che ho cambiato nel menu del render è quella che si trova nella sezione “Sampling” e che di default è impostata a 128. Io l’ho aumentata a 500.

    0
    #539434

    CyberJabba
    Partecipante
    • Blenderista
    • Post sul forum 329
    • Associato Blender Italia

    Non ho idea di quanta ram tu abbia… e la risoluzione non è proprio bassina… prova ad aprire il task manager durante il rendering. Almeno capiamo cosa combina la macchina durante il calcolo (lo Swap del disco, lo tieni attivo o disattivato?). Ultima cosa, che versione di Blender usi?

    CJ

    0
    #539435

    SL31
    Partecipante
    • Blenderista
    • Post sul forum 6

    Grazie dei suggerimenti, proverò più tardi, ora sono impegnato. Comunque, per la RAM, sarò sincero, ho 32GB e una scheda video da 8. Ora sicuramente ti renderai conto ancora di più dell’assurdità della situazione. Uso Blender 2.79.

    A più tardi, allora! Ti farò sapere.

    0
    #539436

    Harvester
    Moderatore
    • Veterano Bronzo
    • ★★★
    • Post sul forum 2471
    • Blender.it Staff
    • Associato Blender Italia

    Qualche indizio in più potresti ricavarlo avviando Blender da linea di comando in modalità Debug: blender.exe –debug

    In questo modo anche se Blender si chiude brutalmente ti restano tutti i messaggi della console.

    Nel caso possa esserti utile ti segnalo un add-on che trovi nella cartella ..\2.79\scripts\addons_contrib\ denominato Render to Print, creato ma Marco Crippa. Lo puoi attivare dal pannello Preferences | Add-ons. Questa invece è una versione più aggiornata ma apparentemente non inclusa negli addon ufficialmente supportati. Dagli un’occhiata.

    1+
    #539701

    SL31
    Partecipante
    • Blenderista
    • Post sul forum 6

    Salve a tutti, ancora una volta. Vi riscrivo, oltre che per avvisarvi che non sono morto, per aggiornarvi sulla situazione. Voglio parlarvi di un fatto che mi ha lasciato parecchio sbalordito. Ho ritentato il render, stavolta con il task manager aperto e sott’occhio, come mi è stato consigliato da CJ. Lì, semplicemente succede la solita roba: altissima percentuale di utilizzo della CPU (come è giusto che sia, dopotutto) da parte di Blender, ma nessuna attività anomala, o almeno non sembrava. Ma il punto qui è un altro: il render è andato liscio dall’inizio alla fine. Niente crash o chiusure inaspettate, niente di niente. Probabilmente, quando avevo provato le volte precedenti, il PC stava eseguendo qualche altra operazione pesante, anche se non mi viene in mente quale potesse essere. Comunque, qualsiasi consiglio su come prevenire quest’eventualità in futuro è sempre ben accetto!

    P.S. Per Harvester: ho dato una rapida occhiata all’add-on che mi hai consigliato, ma purtroppo non ho avuto ancora occasione di scaricarlo. Da quanto ho visto, essenzialmente mi sembra un tool che ti permette di impostare automaticamente la risoluzione del render in base al formato e al DPI, giusto? Se è così, allora la stessa cosa la posso fare su programmi come Inkscape, che uso abitualmente. Vale a dire: mi basterebbe esportare come immagine un documento di Inkscape di date dimensioni (in cm o mm) e vedere, con il DPI impostato, a quale risoluzione me la esporta, no?

    0
    #539721

    Harvester
    Moderatore
    • Veterano Bronzo
    • ★★★
    • Post sul forum 2471
    • Blender.it Staff
    • Associato Blender Italia

    Devi valutare tu stesso se tale funzionalità ti può servire oppure no. Ti ho solo indicato uno strumento potenzialmente utile. 😉

    0
    #556565

    SL31
    Partecipante
    • Blenderista
    • Post sul forum 6

    Rieccomi qua, dopo 4 mesi di assenza, per aggiornarvi sulla situazione. Ho messo da parte il progetto per un po’, per dedicarmi ad altro, riprendendolo solo recentemente, e purtroppo non solo Blender ha ripreso a crashare , ma il tempo stimato per il render è passato da 6 minuti a 20, e anche se ho cambiato alcuni materiali (passando da diffuse e glossy a principled) e l’illuminazione, non credo che sia dovuto a quello.

    Le mie impostazioni di render: 2480×3508; Sampling > Seed: 0; Clamp Direct/Indirect: 1.00; Light Sampling Threshold: 0.00; Render: 512; Preview: 32

    0
Stai vedendo 11 articoli - dal 1 a 11 (di 11 totali)

Devi essere loggato per rispondere a questa discussione.