[Risolto] creare spessore alla mesh

Stai vedendo 7 articoli - dal 1 a 7 (di 7 totali)
  • Autore
    Articoli
  • #580818

    akuma78
    Partecipante
    • Blenderista
    • Post sul Forum 195

    Salve, sto cercando nei vecchi thread una procedura per poter dare spessore ad una mesh curvilinea (non piana).

    Nel mio esempio, ho una fiancata dell’ auto , diciamo che ho modellato tutto ciò che è superficiale ed ora voglio dargli uno spessore. COme modificatore ho provato con solidify, ma il problema di tutte le procedure che seguo è quello di dare uno spessore che sia coerente con la superficie….ossia che vada verso l’ interno dell’ auto rispettando le normali che però variano da sezione a sezione.

    Senza fare una domanda troppo complessa e prolissa, come fareste voi per dare uno spessore alla seguente mesh?

    Forse al posto di solidify si farà un lavoro di estrusione ed aggiustamento in base alle normali e centri di riferimento…attendo consigli grazie


    no
    #580819

    Hullo
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 508

    Io ho sempre utilizzato il solidify flaggando l’opzione only rim e poi sistemando a mano dove necessario…..


    Sicut Nox Silentes
    #580820

    akuma78
    Partecipante
    • Blenderista
    • Post sul Forum 195

    SI ma con solidify il problema si pone perchè la mesh non essendo piana ha tante variazioni di curvatura, ci sono parecchi spigoli accentuati dove la variazione di pendenza è su tutti e 3 gli assi…quindi solidify non si comporta bene e nel provare ad aggiustarlo a mano ho difficoltà…

    nella foto ho evidenziato uno dei tanti spigoli, come vedi lo spessore non rimane costante e mi sembra che nella zona con il cerchio più grosso la retta generata da solidify non sia nemmeno parallela all’ originale ma, verso la punta, tende a curvare


    no
    #580822

    Fangetto
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 478
    • Associato Blender Italia

    metti il flag su even thickness, e su high quality normals, e crea una buona topologia, nella zona da te evidenziata manca un loop di controllo (o retainer loop) per quello l’edge è sghembo, con il loop il problema della non planarità delle 2 facce si risolve bene e comunque resta limitato nello spazio fra gli edge all’angolo.


    Don’t Feed The Trool
    #580823

    akuma78
    Partecipante
    • Blenderista
    • Post sul Forum 195

    Si, decisamente migliora tutto. Adesso dovrei collegare i vari vertici alla mia mesh per chiudere lo spessore, corretto?

    Due domande:

    1. cos’ è un loop di controllo/retainer
    2. se volessi aumentare lo spessore, ma solidify negli angoli incrocerebbe i vertici, devo risolvere puntualmente il problema o c’ è altro modo?

    no
    #580839

    Fangetto
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 478
    • Associato Blender Italia

     

     

    Sono quelli indicati in giallo, in verde quello che manca, hanno la funzione (oltre che a controllare l’azione del subdivision surface) di riportare le normali planari in modo da far riflettere (e illuminare) bene le facce, nell’immagine a sinistra ci sono i control loop e la superfice riflette correttamente a destra ce ne è solamente 1 (quello inferiore) e come puoi vedere il riflesso è distorto e sbagliato.

     

    Si il problema degli spigoli va risolto a mano, o quantomeno non so se c’è un’altra soluzione

     

     

     

     


    Don’t Feed The Trool
    #580900

    akuma78
    Partecipante
    • Blenderista
    • Post sul Forum 195

    Metto come [RISOLTO] perchè forse il mio problema è mal posto.

    Sono partito da una parte di una carrozzeria e di questa parte in alcune zone ho creato lo spessore ed in altre no. Se poi inizio ad applicare solidify dovrei perdere tempo a rivedere la mesh per togliere le parti in eccesso…insomma credo che il problema sia un rivedere la mesh per intero, eliminare gli spessori ed a quel punto rivedere la topologia. Infine applicare solidify.

     


    no
Stai vedendo 7 articoli - dal 1 a 7 (di 7 totali)

Devi essere loggato per rispondere a questa discussione.