Blender Italia forums Supporto Utenti Supporto Animazione e rigging Esportazione animazione senza Background

Status della richiesta: Non è una richiesta di supporto

Taggato: ,

Stai visualizzando 22 post - dal 1 a 22 (di 22 totali)
  • Autore
    Post
  • Jonny
    Membro
    • Blenderista
    • Post sul Forum 17
    #777696

    Buongiorno a tutti e Buona Pasqua,

    Sono un nuovo iscritto e spero che il mio topic non esista già e di essere nell’area corretta.

    Ho installato Blender 2.8.2

    sono molto principiante anche perchè sono venuto a conoscenza di blender casualmente la settimana scorsa.  Ho dedicato parecchio tempo per potermi muovere usando i comandi principali.

    Ho messo al centro della scena due ingranaggi che ruotano ed  ho impostato la camera  che ruota attorno a loro . Ho esportato immagini e video senza problemi .

    La domanda è    :     siccome vorrei esportare l’animazione senza lo sfondo (background) , ho già fatto la sequenza delle immagini senza Background in png di tutti i frame (fleggando Trasparency in Film) , ma quando vado in Video sequencer per esportare il video mi lascia sempre lo sfondo, ho fatto svariate prove ma niente da fare dopo una giornata di prove ho ceduto … sicuramente sarà una banalità ….  ma non so piu cosa fare…. grazie

    andcamp
    Moderatore
    #777698

    Ciao e buona Pasqua,
    |, ma quando vado in Video sequencer per esportare il video mi lascia sempre lo sfondo

    nel senso che quando importi nel VSE scopri che la sequenza ha uno sfondo, oppure non riesci ad esportare in un formato video senza sfondo?


    Jonny
    Membro
    • Blenderista
    • Post sul Forum 17
    #777705

    Ciao e grazie per l’aiuto….

    |, nel senso che quando importi nel VSE scopri che la sequenza ha uno sfondo, oppure non riesci ad esportare in un formato video senza sfondo?

    non riesco ad esportare in un formato video senza sfondo,  le immagini relative ai vari frame (250 ) sono tutte corrette senza sfondo, ma quando riproduco il video (MKV) ha lo sfondo nero

    andcamp
    Moderatore
    #777734

    Devi cercare per il contenitore Matroska un codec video che supporti il canale alpha (RGBA) la cui opzione dovrai selezionare. Per esempio


    Jonny
    Membro
    • Blenderista
    • Post sul Forum 17
    #777739

    grazie mille,

    ho provato,  a fine conversione però quando cerco di visualizzarlo con view animation non mi fa vedere nulla, cliccando direttamente sul file mi da errore in apertura perche non ho il lettore giusto sul mio pc per quel formato. Avendo estensione .MKV (mi pare simile all iphone)  ho provato a convertirlo come faccio di solito con altri video ma nemmeno il convertitore che utilizzo io (conv Video to Video) non lo importa e la cosa strana è che con il software ( P*******e) che utilizzo per fare i montaggi video (amatoriale) mi fa vedere l’immagine sull’icona del file video ma poi quando glielo faccio importare mi da errore formato

    Jonny
    Membro
    • Blenderista
    • Post sul Forum 17
    #777741

    nel frattempo ho provato tutti gli altri formati che mi fanno apparire RGBA ma non riesco a visualizzarli ugualmente

    FFMPEGVIDEO CODEC #1   —  HuffYUV —-  PNG—- Qtrle-QT ANIMATION —-  WEBM-VP9

    ad esempio il png riesco a visualizzarlo (con VLC)  ma ha lo sfondo nero

     

    andcamp
    Moderatore
    #777745

    sì, bisogna avere installato il codec adatto sul proprio pc per poterlo leggere.  Io con installato il pacchetto K-lite, riesco a creare i file .mov con container QTime e
    Qtrle-QT ANIMATION, ma il risultato migliore lo raggiungo (essendo anche un codec  con codifica lossless) con container Matrosca e codec video HuffYUV


    Jonny
    Membro
    • Blenderista
    • Post sul Forum 17
    #777770

    ok, ho scaricato DSO dal sito k-lite è questo che intendi vero? non vorrei installare qualcosa di sbagliato, mi chiede di fare login inserendo la mail … altrimenti se mi puoi indicare il link   grazie

    andcamp
    Moderatore
    #777777

    che io sappia si scarica da qui https://codecguide.com/download_kl.htm

    mi sono dimenticato di dire che è per Windows, se utilizzi un altro sistema operativo bisognerà cercare un altro pacchetto


    Jonny
    Membro
    • Blenderista
    • Post sul Forum 17
    #777790

    grazie, l’ho trovato, scaricato ed installato,  a me va bene perchè ho windows 10

    ho fatto una prova esportando l’animazione  Movie :  FFMpeg Video   Conteiner Matroska  e Video Codec : HuffYUV  e lo legge tranquillamente,  sarò un po distratto ma non son riuscito a trovare il modo di come esportarlo in modo da poterlo visualizzare con il software di montaggio

    andcamp
    Moderatore
    #777807

    Se devi utilizzarlo in un software di montaggio, sei sicuro che non si possa importare in esso la sequenza di png trasparenti?


    Jonny
    Membro
    • Blenderista
    • Post sul Forum 17
    #777815

    si le immagini png trasparenti le posso importare il fatto è che sono 250 per tutta l’animazione , invece se importo il video lo gestisco meglio … però ora che ci penso mi hai dato un grande spunto perchè posso caricare le immagini impostando anziche 3 secondi a  sec 0.01 ed a questo punto se mi fa esportare il video con trasparenza sono a posto, cosi dopo lo posso sovrapporre al resto importandolo… dopo provo

    Jonny
    Membro
    • Blenderista
    • Post sul Forum 17
    #777855

    ho provato ed ogni tanto il sistema cade, anche perchè quando gli trascino sulla Timeline le 250 immagini con il valore 00.01 sec mi da errore ma poi le prende e quando do il play l’animazione funziona. Rimane il problema che in esportazione (facendo piu prove) mi torna lo sfondo nero dietro, visto pero che devo mettere quest ainmazione in un angolo in alto della videata e lo sfondo per mia fortuna è tinta unita la risolvo in questo modo altro non saprei piu cosa provare.  Il mio software di montaggio importa il formato .mkv ma evidentemente con il codec H264,  fosse predisposto alla lettura del codec QTanimation oppure HuffYUV lo gestirei meglio …..correggimi se ho capito male sono poco informato in merito….

    Jonny
    Membro
    • Blenderista
    • Post sul Forum 17
    #777883

    forse potrei riuscire a farlo funzionare (sul software dove faccio il montaggio) ma dovrei esportare un filmato con sfondo verde, ho provato piu volte con blender (riutilizzando le immagini png con sfondo trasparente) ma continua a farmi il filmato con lo sfondo nero, c’è un modo per far uscire un filmato con sfondo verde? spero di non dover rifare le immagini …  :-(

    Jonny
    Membro
    • Blenderista
    • Post sul Forum 17
    #777886

    ho rifatto le immagini salvando una nuova animazione ma quando lo importo nell’altro software mi rende lo sfondo trasparente ma rovina gli altri colori … non so piu cosa fare…

    andcamp
    Moderatore
    #777890

    |forse potrei riuscire a farlo funzionare (sul software dove faccio il montaggio) ma dovrei esportare un filmato con sfondo verde

    Nel VSE puoi mettere sotto alla sequenza di immagini (nel mio caso un cubo che ruota con sfondo trasparente) un’immagine color verde 255 ed esportarlo come mp4


    Jonny
    Membro
    • Blenderista
    • Post sul Forum 17
    #777909

    grazie mille,  provo col tuo suggerimento, però come posso raggiungere il tuo risultato? il tuo cubo è privo di riflessi mentre il mio in alcune zone diventa quasi verde come se prendesse i riflessi

    Jonny
    Membro
    • Blenderista
    • Post sul Forum 17
    #777910

    ok scusa ho riletto meglio ora ho capito

     

    Jonny
    Membro
    • Blenderista
    • Post sul Forum 17
    #777911

    ok grazie mille ho quasi risolto,  ancora una cosa, come posso settare i parametri in modo da ottenere il massimo della qualita?

    grazie ancora

     

    andcamp
    Moderatore
    #777912

    |come posso settare i parametri in modo da ottenere il massimo della qualita?

    dipende dal codec e dipende dalla strategia
    se si vuole che sia un po’ compresso, ma che non vi sia perdita di dati, si sceglie Output Quality: Lossless. Ma il file dopo quanto sarà grande? Verrà importato da tutti i programmi?
    Oppure puoi comprimerlo, ma mantenendo la qualità al massimo con Output Quality: High Quality, magari agendo sui tempi di compressione che prevederanno magari più passate per comprimere il comprimibile (Coding speed: slowest), aumentando però i tempi di codifica e forse anche di decodifica


    Jonny
    Membro
    • Blenderista
    • Post sul Forum 17
    #777922

    ho fatto un po di prove e direi che va bene grazie mille …..    ora pero non mi fa dovevo fare altre Render Image e non so per quale motivo quando appare la pagina dell’image ci sono solo i quadretti piccoli e l’immagine non appare ho provato a farla con e senza la spunta nel trasparence sotto Film ma non cambia, ho ricontrollato i parametri con un altra scena ma sembra che sia tutto a posto… non capisco cosa posso aver fatto, è come se avessi spento la camera ma dai parametri mi sembra tutto ok….. sapresti dirmi cosa posso fare ? grazie

    Jonny
    Membro
    • Blenderista
    • Post sul Forum 17
    #777923

    tutto a posto ho risolto grazie comunque, avevo lasciato un file nella VS , ho cancellato quello ed è tornato tutto a posto grazie ancora

Stai visualizzando 22 post - dal 1 a 22 (di 22 totali)
  • Devi essere connesso per rispondere a questo topic.