Ho un problema: ambigua trasparenza solidi

Stai vedendo 13 articoli - dal 1 a 13 (di 13 totali)
  • Autore
    Articoli
  • #15933

    ANDREABAZ
    Partecipante
    • Blenderista
    • Post sul forum 50

    Ok allora: entro in game e noto che vedo una ambigua trasparenza degli oggetti creati, non ho settato trasparency. Soluzioni?

    Aiuto vi prego, è un progetto importante e mi sono bloccato.

    Poi ogni tanto cambio angolazione e vedo proprio attraverso il solido! ma…ma

    A voi!

    #181789

    Qwerty
    Partecipante
    • Veterano
    • ★★
    • Post sul forum 456

    Strano…

    Puoi postare delle immagini?

    Usi i GLSL o no?

    #181790

    ANDREABAZ
    Partecipante
    • Blenderista
    • Post sul forum 50

    Allora io uso Multitexture perchè se vado in GLSL vedo tutto bianco O.o

    vedi:

    By filippodas at 2010-10-18

    By filippodas at 2010-10-18

    By filippodas at 2010-10-18

    #181791

    Qwerty
    Partecipante
    • Veterano
    • ★★
    • Post sul forum 456

    e quali sono le parti trasparenti?

    #181792

    ANDREABAZ
    Partecipante
    • Blenderista
    • Post sul forum 50

    2a immagine: qui specie di boccali fatti dietro che si vedono stranamente anche dalla fisuale frontale

    3a immagine: (in alto) quelle specie di linee strane rosse su grigio

    E poi non vedo le ombre!!! Ma che succede!

    #181793

    Qwerty
    Partecipante
    • Veterano
    • ★★
    • Post sul forum 456

    Mah… o sono le normals in direzioni sbagliate, o è l’immagine ad aver parti trasparenti (ma mi sembra improbabile) o ci sono delle facce sovrapposte…. Non saprei esattamente… e inoltre non sono un “gran maestro” del Ge 😉

    #181794

    GiganteBaba
    Partecipante
    • Blenderista
    • Post sul forum 122

    Sa sai settare bene le trasparenze per GLSL?

    attiva lo ZTransp, modifica l’alpha al livello che ti serve ed è fatta.

    #181795

    ANDREABAZ
    Partecipante
    • Blenderista
    • Post sul forum 50

    si ma perchè vado in game e vedo tutto bianco con GLSL?

    #181796

    Qwerty
    Partecipante
    • Veterano
    • ★★
    • Post sul forum 456

    Ipotesi (il mio computer non supporta i GLSL): hai assegnato a ogni oggetto un materiale (non bianco, ovvio)?

    #181797

    IzE_Design
    Partecipante
    • Blenderista
    • Post sul forum 202

    a prima vista hai le normali girate, prova ad entrare in edit mode, selezionare tutto e premere CTRL+N

    #181798

    ANDREABAZ
    Partecipante
    • Blenderista
    • Post sul forum 50

    esatto! adesso per vedere le ombre che faccio? non sembrano vedersi! e poi ho ancora il problema di tutto bianco in GLSL

    #181799

    ANDREABAZ
    Partecipante
    • Blenderista
    • Post sul forum 50

    ecco grazie! problema risolto! Mi linkate magari una guida sulle ombre sul game engine? e poi anche su GLSL E MULTITEXTURE…ditemi la differenzae grazie cmq!

    #181800

    Qwerty
    Partecipante
    • Veterano
    • ★★
    • Post sul forum 456

    I GLSL funzionano grosso modo con i materiali normali: textures, normal maps etc.

    Il multitexture sotto questo profilo è molto scomodo: niente normal maps, bassa qualità  (ovviamente relativa a vertici e textures), problemi con ombre, trasparenze etc.

    Non avendo i GLSL mi sono dovuto ingegnare: per le ombre uso uno script che proietta una copia dell’oggetto semitrasparente sul pavimento.

    Guide purtroppo non te ne so consigliare…

Stai vedendo 13 articoli - dal 1 a 13 (di 13 totali)

Devi essere loggato per rispondere a questa discussione.