Stai visualizzando 15 post - dal 1 a 15 (di 15 totali)
  • Autore
    Post
  • edraghet
    Membro
    • Blenderista
    • Post sul Forum 6
    @edraghet
    #762644

    Buongiorno a tutti,
    sono Lele e da poco sto buttando la testa in blender per fare animazioni di processi meccanici.
    Chiedo scusa in anticipo qualora dovesse esserci un post simile….sono ancora un po’ asciutto sui termini tecnici di Blender.

    Vorrei fare in modo che un oggetto (poniamo il semplice cubo) sparisca nel tempo…frame 1 al 100% e frame 20 –> 0%, utilizzando Eevee.
    Vengo da 3DS e lì semplicemente si aggiungeva una richiesta di visibilità nel graph editor. Non riesco a trovare nulla di simile in Blender.

    Potreste indicarmi un metodo?

    Grazie tutti e complimenti x la community….bellissima.

    Emanuele

    globante
    Partecipante
    • Blenderista
    • Post sul Forum 162
    @globante
    #762774

    Trasparenze in blender 2.8

    Ciao edraghet

    1) crea la tua scena e nel menù “viewport Shading” seleziona il tasto “rendered”
    2) seleziona l’oggetto che vuoi rendere opaco assegnagli un materiale.
    3) Sempre con l’oggetto selezionato, nel tab “context materiali”, trovi sotto il menu “Settings”, il parametro “Blend Mode” scegli nel suo menù a tendina la voce “Alpha Blend”
    4) adesso creiamo l’animazione: vai al frame 1 e attiva “Auto Keyng”
    5) torna nel tab “context materiali”, al parametro “ALPHA” che ha di defaul il valore “1” clicca col tasto Dx per fare apparire un menù contestuale e scegli “insert keyframe”
    6) Al frame 1 è apparso il “keyframe”, spostati su un frame a tuo piacimento io metto 80.
    7) torna nel tab “context materiali”, al parametro “ALPHA” che ha il valore “1” cambialo in “0”
    8) Al frame 80 è apparso il “keyframe”
    9) fai partire l’animazione e vedi il risultato da te sperato.

    Saluti Globante

    Ps. se vuoi far sparire la sua ombra, vai nel tab “context materiali”, trovi sotto il menu “Settings”, il parametro “Shadow Mode” scegli nel suo menù a tendina la voce “none”.

    edraghet
    Membro
    • Blenderista
    • Post sul Forum 6
    @edraghet
    #762786

    Grazie mille. Capito come uno grande!!!

    dirak81
    Membro
    • Blenderista
    • Post sul Forum 9
    @dirak81
    #832703

    Ciao, ri-apro questo thread, per avere delle informazioni in più riguardante la domanda già posta da edraghet.

    Prima di trovare questo post, avevo già provato la soluzione di globante, ma devo aver sbagliato qualcosa, provo ora a spiegarmi.

    Praticamente la mia idea era quella di togliere una “fetta”(che è un solido a se) della torta che vedrete nel filmato, cosi da vedere l’interno.

    Il problema è che si vedono dei salti di colore, nelle superifici di contatto della “fetta” e della restante “torta”, passatemi il termine.

    Per ovviare a questo problema, avevo inserito dei keyframe, dove l’oggetto che diventava trasparente(tramite il valore alpha), era fino ad un certo punto renderizzato, e poi quando la trasparenza era totale, non doveva essere più renderizzato.

    Ps. se vuoi far sparire la sua ombra, vai nel tab “context materiali”, trovi sotto il menu “Settings”, il parametro “Shadow Mode” scegli nel suo menù a tendina la voce “none”.

    Volevo capire se il parametro shadow mode:none deve essere spuntato sin dall’inizio o meno.

    Sicuramente non è il modo corretto, spero possiate darmi qualche indicazione su come si potrebbe fare.

    Grazie mille.

    Nanni Marras
    Partecipante
    @nn81
    #832707

    mi suona come un problema di z-fighting, ci sono facce della fetta che si sovrappongono/combaciano con quelle del resto della torta (passami la metafora)?

    dirak81
    Membro
    • Blenderista
    • Post sul Forum 9
    @dirak81
    #832710

    Potrebbe essere, avendo creato i solidi su autocad, sia i piatti sopra e sotto che la parce cilindrica…quindi praticamente le facce combaciano.

    Ma qual’è la corretta procedura per far scomparire gradualmente un’oggetto? azzerando il canale alpha sulla timeline, tramite i keyframe, pensavo che tutto il pacchetto(ombre ecc) andasse sfumando…

    Non mi è chiaro il funzionamento del “Blend mode” e del “Shadow mode” in Material Properties-> viewport display->setting.

    Nanni Marras
    Partecipante
    @nn81
    #832712

    in tal caso lo z fighting è palese, immaginalo nella realtà non dovrebbero essere sovrapposti, potresti ad esempio selezionare della fetta le facce incriminate e farle rientrare leggermente verso l’interno in modo che non risultino più perfettamente sovrapposte (aiutati zumando da vicino e tenendo ppremuto shift quando esegui la operazione di spostamento così è proprio infinitesima)

    per le modalità di blend e shadow del materiale ti consiglio di dare una veloce letta alla pagina della documentazione relativa dopodichè di cercare dei tutorialini esplicativi specifici perchè un video vale più di mille parole

    Nanni Marras
    Partecipante
    @nn81
    #832731


    @dirak81
    stavo facendo una prova veloce, vedi se risolvi con lo z-fighting disattivando l’opzione “show backface” che esce quando setti alpha blend al posto di opaque

     

     

    dirak81
    Membro
    • Blenderista
    • Post sul Forum 9
    @dirak81
    #832748

    Vedi?quando uno sà dove mettere le mani, le cose sono semplicissime!

     

    Grazie mille NN81, appena ho un attimo ci metto mano.

    Quindi, in parole povere, il materiale dell’oggetto che deve sparire, deve avere nella casella blend mode=Alpha blend e non devo spuntare la casella Show backface(che in effetti a logica, potrebbe essere d’aiuto).

    Grazie di nuovo.

    dirak81
    Membro
    • Blenderista
    • Post sul Forum 9
    @dirak81
    #832803

    Allora ho provato a fare la stessa prova che hai fatto tu, ma ovviamente non poteva essere cosi semplice.

    Ho creato i 3 cubi, e ho dato colori base, modificando solo la tonalità.

    Ho creato sulla timeline l’effetto trasparenza, dando al cubo centrale nel blend mode=alpha blend e togliendo la spunta su show backface.

    I cubi sono a contatto, quindi con il problema dello z-fighting…però volevo vedere se come mi hai suggerito tu, riuscivo a risolvere.

    Niente… questo è il risultato!

    Non sò come mai, ma non posso caricare il file .blend per farti vedere se le impostazioni sono corrette…ma lo dovrebbero essere, non avendo praticamente toccato nulla.

    Nanni Marras
    Partecipante
    @nn81
    #832805

    ma non posso caricare il file .blend per farti vedere se le impostazioni sono corrette…ma lo dovrebbero essere, non avendo praticamente toccato nulla.

    dovresti poterlo caricare dal tuo profilo sezione risorse condivise (assicurati dopo l’upload che sia con impostazione privacy “pubblico”) al limite carica e condividi link da altrove

    va bene anche questo sample dei cubi tanto l’errore c’è comunque basta per dare una controllata

    dirak81
    Membro
    • Blenderista
    • Post sul Forum 9
    @dirak81
    #832816

    Grazie mille intanto per la disponibilità e la pazienza! :+1:

    Ecco il file

    Ovviamente, per controprova, spostando il cubo centrale di pochissimo, và tutto liscio come l’olio, e non serve addirittura il blend mode  in alpha.

    Per implementare la difficoltà, e dato che è anche una cosa che mi è capitata sul render del progetto che ho fatto,

    ho inserito delle barre gialle dentro al cubo che deve sparire, e che a loro volta, ma solo in un secondo momento, anche queste devono venire meno.

    L’intersezione fra i due, anche in questo caso da un problema analogo a quello dei cubi.

    Probabilmente stò pensando che sbaglio l’approccio, nel senso che devo modellare come fosse nella realtà, quindi con il cubo “forato” per far spazio alle barre gialle.

    :unsure:

     

    Nanni Marras
    Partecipante
    @nn81
    #832819

    ohh cacchio non avevo capito che lo stavi facendo su Cycles, io stavo usando fisso eevee

    non sono pratico con Cycles pero’ provo a darci uno sguardo ugualmente

    Nanni Marras
    Partecipante
    @nn81
    #832823

    niente non ne ho cavato piede, una veloce ricerca su google confermerebbe che non sia possibile eludere lo zfighting in quel contesto

    la cosa migliore a sto punto sarebbe se lo modellassi il tutto come pezzi realmente distaccati anche se di un pelo in modo che le facce non vadano a overlapparsi perfettamente..

    attendi comunque altri feedback, come ti dicevo io non son pratico su Cycles ma c’è tanta gente in giro sul forum che lo è, magari vien fuori una soluzione..

    su eevee comunque dovrebbe andare, probabilmente uno dei “deficit” delle proprietà render di eevee rispetto a cycles in particolari frangenti come questo può rivelarsi  utile (in quel thread che ho linkato si legge addirittura dell opzione Zoffset su blender internal render :sleepy: ), valuta al limite se puoi risolvere facendo il lavoro su eevee

    dirak81
    Membro
    • Blenderista
    • Post sul Forum 9
    @dirak81
    #832999

    Grazie per averci perso tempo intanto.

    Ho fatto un pò di prove, anche per il discorso delle barre.

    Ho pensato che se con i cubi, spostandoli di un millimetro, non avevo problemi di interferenza nel render,

    forse,

    creando il foro nel cubo e poi mettendoci la barra, senza che nessuna superficie si sovrapponesse, avrei avuto dei buoni risultati, invece niente.

    Idem con patate! 😥

     

    Proverò a vedere se usando eevee il problema si risolve e se il risultato finale possan andare.

    Ancora grazie NN81. :+1:

     

Stai visualizzando 15 post - dal 1 a 15 (di 15 totali)
  • Devi essere connesso per rispondere a questo topic.