Status della richiesta: Non è una richiesta di supporto
Stai visualizzando 10 post - dal 1 a 10 (di 10 totali)
  • Autore
    Post
  • #519744

    Ciao ragazzi, mi stavo scrociando col mycropoligon displac e come visto sui tutorial di Price e Alexandrow i particellari come anche le normal map non sembrano andare!. Soprattutto sui particellari avete qualche dritta?

    Grazie anticipatamente!

    #519745

    ciao luca, per quanto riguarda le normal map ho notato che creano problemi se il nodo “normal map” è settato su “tangent space”, cambiando su “object space” il materiale e il microdispl. tornano a funzionare (non so se la cosa può esserti utile).

    per le particelle non so dirti.

    ciao

    pix


    architetto freelance – CG artist
    #519762

    si vero, funzionano in object space ma così e cosi… Stavo facendo un cappello di lana e mi piaceva l’idea di usare il micropoligon ma i particellari x la peluria non funzionano :(

    Harvester
    Moderatore
    #519763

    Poichè il modificatore Subdivision Surface deve essere l’ultimo nella serie di modificatori applicati alla mesh, ciò comporta l’impossibilità per il sistema particellare di adattarsi alla superficie poichè essa viene calcolata solo al momento del rendering.

    Per quanto riguarda la normal map essa non funziona con il microdisplacement e consiglio di usare in sua vece il nodo Bump Map ed una texture in scala di grigi.

    Dalla documentazione di May Lavelle viene fuori che i valori di displacement devono essere moltiplicati di un fattore 10 prima di essere utilizzati. Inoltre, in base al tipo di texture ed alla profondità di bit può rendersi necessario adattare il punto mediano della texture. Questo è un esempio di nodi:

    In questo video vengono spiegati alcuni accorgimenti da usare con le texture quando alimentano il microdisplacement:

    Cycles – Displacement Textures Tips (Microdisplacement Blender 2.7)

     

    #519764

    grazie! ottima spiegazione

    Anfeo
    Partecipante
    #519769

    Più che altro le normal di solito sono usate per simulare un finto displace, quindi è normale che non sia stata presa in considerazione l’idea di far fare le cose ad entrambi.

    Il processo normale è  Normal Map per i dettagli grandi e Bump per quelli fini, oppure Displace per quelli grandi e Bump per quelli fini.

    Per le particelle potresti creare un duplicato della mesh e gestire lì il sistema particellare, una pratica molto più professionale che avere tutto sulla mesh principale (poi puoi settare che si vedano solo le particelle e non la mesh del duplicato).

    Occhi infine a non abusare del microdiplacement, in certi casi non serve proprio.

    Qui avevo usato solo una normal+bump (tra l’altro con l’internal):

    http://www.3dtotal.com/galleries/image/Character/5255-scarecrow-by-anfeo-horror-scary-halloween#readers_comments


    #519784

    si, infatti infine ho duplicato la mesh infine. Bella immagine Alfonso!

    In sostanza per oggetti animati con particari meglio lasciarlo stare il micropoligon, ad esempio su tessutti super dettagliati

     

    Anfeo
    Partecipante
    #520000

    In sostanza per oggetti animati con particari meglio lasciarlo stare il micropoligon, ad esempio su tessutti super dettagliati

    Dipende sempre, se hai bisogno di un dettaglio  stile formica sul maglione lo usi.


    Filippo
    Membro
    • Blenderista
    • Post sul Forum 2
    #520774

    Ciao a tutti. La premessa è che sono un neofita, il problema invece è che sto cercando di creare un prato davanti ad una architettura. Ho modellato un piano adattandolo alla forma del lotto e ritagliando le superfici di sedime occupate dal fabbricato e dai vialetti di accesso. Ho attivato il sistema particellare su Hair e dopo le impostazioni di base per creare i fili d’erba, ho attivato la scheda Children e clickato Simple. Fatto questo mi ritrovo con ciuffi d’erba, (children), parzialmente anche sulle parti che ho ritagliato dal piano, ossia anche sui vialetti e sul sedime occupato dal fabbricato che in realtà non presentano superficie. Non solo: nonostante abbassi il valore Clump al massimo, le dimensioni dei children rimangono comunque eccessive rispetto alla scala del modello. Dove sbaglio? Sperando di essere stato chiaro nella speigazione, ringrazio sin d’ora l’anima buona che vorrà aiutarmi. ;-) Buona serata.

    Harvester
    Moderatore
    #520776

    Ciao Filippo. Avresti dovuto creare una nuova discussione per illustrare il tuo problema poiché non ha nulla a che fare con questa specifica discussione. Diversamente sarebbe il caos, non credi? Per questa volta sei perdonato ma fai attenzione in futuro. ;-)

Stai visualizzando 10 post - dal 1 a 10 (di 10 totali)
  • Devi essere connesso per rispondere a questo topic.