Blender Italia Forum Supporto Utenti Supporto Materiali e texture Norma maps BI o Cycles?

Taggato: ,

  • Questo topic ha 14 risposte, 3 partecipanti ed è stato aggiornato l'ultima volta 4 anni, 3 mesi fa da alex.
Stai visualizzando 15 post - dal 1 a 15 (di 15 totali)
  • Autore
    Post
  • waaf
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 609
    @waaf
    #573743

    Ragazzi, qualcuno mi spiega se ci sono problemi ad usare in Cycles  normal maps bakerizzate con l’internal? Perché Cycles ci mette veramente troppo tempo,sempre se non mi fa crashare blender….

    Harvester
    Moderatore
    @harvester
    #573745

    Una normal map è la stessa sia che tu la usi in BR che in Cycles. Quanto grande ed in che formato è? Cycles ci mette troppo tempo … a fare che cosa? Il baking?

    waaf
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 609
    @waaf
    #573746

    Forse mi sono spiegato male…Io userei Cycles per il rendering. Ma fare il bake dall’ Internal da come risultato una normal diversa da quella prodotta da Cycles?

    Sarebbe dell’ ordine dei 6000×6000, ma anche testando con una 1024×1024 sono almeno 4 ore che cycles macina a fare il bake, bloccando completamente il PC. Sì, la mesh hires è abbastanza pesante…però ricordo che con altri progetti fare il Bake dall’ Internal era molto più rapido

    Harvester
    Moderatore
    @harvester
    #573748

    In teoria i risultati dovrebbero essere identici. Potrebbe essere che non hai abbastanza memoria e il Baking fa lo swap del disco fisso.

    waaf
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 609
    @waaf
    #573772

    boh…ho 16gb di RAM…il modello hires effettivamente è pesantuccio…

    Harvester
    Moderatore
    @harvester
    #573779

    Mi pare tu abbia memoria sufficiente quindi i tempi di baking sono dovuti alla complessità del modello High Poly. Nel caso fai il baking con Blender Render se vedi che i tempi sono inferiori rispetto a Cycles.

    alex
    Partecipante
    • Blenderista
    • Post sul Forum 288
    @alexsdraub
    #573790

    per quello che ho capito i risultati non sono proprio identici, lo so per certo per le Ambient Occlusion per le normal non ho la certezza, più probabilmente non so ( e nemmeno quelli che fanno i tutorial) usare al meglio il baking di cycles

    Harvester
    Moderatore
    @harvester
    #573794

    La qualità del baking AO in Blender Render dipende dalle impostazioni che usi. Di norma lascio che sia Cycles a calcolare queste cose, inoltre non mi interesso di gaming nè di texturing per il gaming, l’unica ragione per cui ha forse senso (non so per quanto) aggiungere AO (multiply) all’immagine del colore diffuso.

    Comunque, ho fatto una semplice prova con un modello dotato di quasi duecentomila vertici dopo averlo scolpito e non ho notato particolari problemi. L’unico accorgimento adottato è stato quello di creare un’immagine a 32bit per il baking in 4K.

     

    waaf
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 609
    @waaf
    #573807

    Il baking dell’ AO non l’ho fatto e non so neanche se lo farò. La mia mesh hipoly è di circa 17 milioni di poligoni…però è strano che con l’ internal bakerizzo tranquillamente in tempi accettabili, mentre con Cycles ciò non accade.

    alex
    Partecipante
    • Blenderista
    • Post sul Forum 288
    @alexsdraub
    #573840

    visto l’argomento continuo qui

    sto cercando di fare un baking in cycles  delle normali di un busto che ho scolpito e fatto una retopology

    le mappe delle normali sembrano decenti ma quando le applico si vedono degli artefatti come se non fosse appllicato lo smooth che eppure è presente chi mi da una mano? allego le foto per dare un’idea

    Harvester
    Moderatore
    @harvester
    #573841

    Certi artefatti possono essere causati dalla risoluzione insufficiente della mappa. Valuta se sia opportuno crearla in formato EXR a 32bit. Prova anche a creare mappe di dimensioni contenute (512×512 per esempio) ma sempre a 32bit. Potrebbe essere sufficiente se non devi fare dei primissimi piani, ma fai comunque qualche prova prima.

    alex
    Partecipante
    • Blenderista
    • Post sul Forum 288
    @alexsdraub
    #573843

    non penso si dovtuo alla risoluzione questa è in 4k mentre prima era sempicemente 1080 e il tipo di artefatti era uguale, probabilmente la mappa delle normali anche se bella a vedersi è completamente sbagliata ma non so dove cercare l’errore

    Harvester
    Moderatore
    @harvester
    #573844

    Ricordati se non l’hai fatto di applicare lo Smooth sia al modello High Poly che a quello Low Poly prima di fare il bake. Leggi sopra il mio commento sulla risoluzione e sulla profondità di bit della mappa.

    Comunque, i colori nell’immagine della mappa delle normali che hai postato sopra mi sembrano piuttosto strani, estremi, come se il sistema di coordinate fosse Generated or Object e non UV mappato. Ma potrei sbagliarmi.

    alex
    Partecipante
    • Blenderista
    • Post sul Forum 288
    @alexsdraub
    #573845

    grazie dei consigli, in parte ho risolto perché nelle svariate prove settaggi avevo cambiato il baking space  delle Normali da Tangent su Object (((((

    ora le NORMALI son normali ))) anche se il risultato non mi soddisfa ancora

    alex
    Partecipante
    • Blenderista
    • Post sul Forum 288
    @alexsdraub
    #573846

    penso di aver risolto, c’è ancora qualche errore ma in linea di massima era il risultato sperato, forse devo migliorare l atopologia o il processo di baking

    Grazie Harvester sei sempre presente nel momento del bisogno!

Stai visualizzando 15 post - dal 1 a 15 (di 15 totali)
  • Devi essere connesso per rispondere a questo topic.