Blender Italia forums Supporto Utenti Supporto hardware NVIDIA X Server Settings per doppio monitor su Ubuntu

Status della richiesta: Non è una richiesta di supporto

Taggato: 

Stai visualizzando 6 post - dal 1 a 6 (di 6 totali)
  • Autore
    Post
  • Scrondo1962
    Partecipante
    • Blenderista
    • Post sul Forum 19
    @scrondo1962
    #842716

    Buongiorno a tutti,

    chiedo aiuto in merito ad un problema inerente all’installazione di un secondo monitor su un sistema Linux (Ubuntu Studio 20.04).

    Ho aperto “NVIDIA X Server Settings” dal menu Impostazioni, i 2 monitor sono stati regolarmente rilevati, nella sezione “X Server Display Configuration” ho settato queste impostazioni:

    procedo quindi con Apply e Save to X Configuration File.. (dopo aver inserito anche la password richiesta per il salvataggio)

    Tuttavia quando vado a chiudere la finestra “NVIDIA X Server Settings” mi restituisce questo messaggio:

    Se Esco e poi riavvio il sistema tutto ritorna come se non avessi fatto nulla, con i due schermi come se li avessi appena collegati.

    A questo punto ho provato ad avviare “NVIDIA X Server Settings” da terminale con sudo nvidia-settings ma mi restituisce un errore:

    bubi@bubi-PC-linux:~$ sudo nvidia-settings

    [sudo] password di bubi:

    (nvidia-settings:4148): GLib-GObject-CRITICAL **: 08:33:38.035: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed

    ** Message: 08:33:38.333: PRIME: No offloading required. Abort

    ** Message: 08:33:38.333: PRIME: is it supported? no

     

    Successivamente, quando tento il salvataggio della configurazione me ne restituisce un’altro:

    Package xorg-server was not found in the pkg-config search path.

    Perhaps you should add the directory containing `xorg-server.pc’

    to the PKG_CONFIG_PATH environment variable

    No package ‘xorg-server’ found

     

    Ho tentato di cercare su Google qualche informazione a riguardo ma nessuna che si avvicinasse minimamente.

    Grazie a tutti coloro che vorranno aiutarmi

    Marco (BO)

    joaulo
    Partecipante
    @joaulo
    #842719

    Personalmente preferisco gestire il multimonitor dal pannello dedicato del Desktop Environment piuttosto che da nvidia-settings, di solito utilizzo nvidia-settings solo per il setup del profilo energetico della scheda…

    In ogni caso, il file xorg.conf è di proprietà dell’amministratore, per scriverci sopra hai dato la password di root immagino e non quella di utente, è corretto?

    Hai verificato che il file esista in /etc/X11/ ?

    E hai controllato se dopo che applicato le modifiche il file sia stato effettivamente modificato?

    Io ti consiglierei di fare un tentativo di setup con l’apposito strumento per il tuo desktop environment.


    Fare. O non fare. Non c’è provare.” – Maestro Yoda

    Scrondo1962
    Partecipante
    • Blenderista
    • Post sul Forum 19
    @scrondo1962
    #842724

    Ciao joaulo, piacere di risentirti, se sei quello dei tutorial linux di youtube ci siamo gia’ sentiti… e grazie dell’interessamento.

    Per la password di root si, ho dato quella.

    Per il file xorg.conf esiste e, in effetti si modifica la data di accesso al file stesso e qualcosa al suo interno nella sezione Screen.

    PRIMA

    Section “Screen”

     

    # Removed Option “metamodes” “DVI-D-0: nvidia-auto-select +1920+0, HDMI-1: nvidia-auto-select +0+0”

    # Removed Option “metamodes” “HDMI-1: nvidia-auto-select +0+0, DVI-D-0: nvidia-auto-select +1920+0”

    # Removed Option “metamodes” “HDMI-1: nvidia-auto-select +0+0, DVI-D-0: 1920x1200_60 +1920+0”

    # Removed Option “metamodes” “HDMI-1: nvidia-auto-select +0+0, DVI-D-0: nvidia-auto-select +1920+0”

    Identifier     “Screen0”

    Device         “Device0”

    Monitor        “Monitor0”

    DefaultDepth    24

    Option         “Stereo” “0”

    Option         “nvidiaXineramaInfoOrder” “DFP-0”

    Option         “metamodes” “nvidia-auto-select +0+0”

    Option         “SLI” “Off”

    Option         “MultiGPU” “Off”

    Option         “BaseMosaic” “off”

    SubSection     “Display”

    Depth       24

    EndSubSection

    DOPO

    Section “Screen”

     

    # Removed Option “metamodes” “DVI-D-0: nvidia-auto-select +1920+0, HDMI-1: nvidia-auto-select +0+0”

    # Removed Option “metamodes” “HDMI-1: nvidia-auto-select +0+0, DVI-D-0: nvidia-auto-select +1920+0”

    # Removed Option “metamodes” “HDMI-1: nvidia-auto-select +0+0, DVI-D-0: 1920x1200_60 +1920+0”

    # Removed Option “metamodes” “HDMI-1: nvidia-auto-select +0+0, DVI-D-0: nvidia-auto-select +1920+0”

    # Removed Option “metamodes” “nvidia-auto-select +0+0”

    Identifier     “Screen0”

    Device         “Device0”

    Monitor        “Monitor0”

    DefaultDepth    24

    Option         “Stereo” “0”

    Option         “nvidiaXineramaInfoOrder” “DFP-0”

    Option         “metamodes” “DVI-D-0: nvidia-auto-select +1920+0, HDMI-1: nvidia-auto-select +0+0”

    Option         “SLI” “Off”

    Option         “MultiGPU” “Off”

    Option         “BaseMosaic” “off”

    SubSection     “Display”

    Depth       24

    EndSubSection

    Tuttavia la questione non cambia.

    Ora provo con lo strumento Schermo dell’ambiente Desktop e ti so dire.

    A presto e grazie ancora

    Marco

    Scrondo1962
    Partecipante
    • Blenderista
    • Post sul Forum 19
    @scrondo1962
    #842726

    Con lo strumento dell’ambiente Desktop funziona e le impostazioni rimangono.

    Il file xorg.conf non viene minimamente toccato (non so il perche’).

    Tuttavia (da ignorante) mi chiedo: ma se il file xorg.conf e’ quello che contiene le informazioni per i monitor, perche’ ora funziona benche’ non vi sia stata immessa alcuna informazione aggiuntiva rispetto a prima?

    Ciao

    Marco

     

     

    joaulo
    Partecipante
    @joaulo
    #842731

    Piacere mio, mi fa sempre piacere provare ad aiutare utenti Linux.

    Purtroppo venire a capo di tutti i passaggi tra tutti i tool che agiscono a livello del server grafico può essere complicato.

    Diciamo che xorg.conf è il file di partenza e contiene le informazioni che il server X carica all’avvio, poi però possono intervenire diversi strumenti a “sovrascrivere” le impostazioni di default. In questo momento non ricordo come agisce il tool di setup del Desktop Environment (forse tramite script xrandr al login) ma il succo è che quando arrivi al login il server è attivo con le impèostazioni di default, quando fai il login vengono caricate altre impostazioni sopra a quelle di default.

    Il tool Nvidia invece và a scrivere nel file xorg.conf e funziona bene se nessun altro tool successivamente cambia le impostazioni.

    Piccola parentesi, nelle distro moderne il file xorg.conf non è più necessario e può essere cancellato, il sistema autorileva le impostazioni. Beh quasi sempre 🙂


    Fare. O non fare. Non c’è provare.” – Maestro Yoda

    Scrondo1962
    Partecipante
    • Blenderista
    • Post sul Forum 19
    @scrondo1962
    #842736

    Grazie di tutto e…… ai prossimi tutorial 😉

Stai visualizzando 6 post - dal 1 a 6 (di 6 totali)
  • Devi essere connesso per rispondere a questo topic.