Blender Italia Forum Supporto Utenti Supporto Materiali e texture oggetto nero quando provo a duplicare texture

  • Questo topic ha 9 risposte, 5 partecipanti ed è stato aggiornato l'ultima volta 1 mese fa da fenix.
Stai visualizzando 10 post - dal 1 a 10 (di 10 totali)
  • Autore
    Post
  • elena01
    Partecipante
    • Blenderista
    • Post sul Forum 7
    @elenatrombetta
    #868681

    buongiorno a tutti!

    quando cerco di “duplicare” o “triplicare” (non so i termini esatti perdonatemi), (Lezione 21: materiali 2, uso delle texutre), la texture si comporta in questo modo anomalo. Sapreste aiutarmi? sicuramente c’è qualcosa di sbagliato ma che non vedo

    Vi metto lo screen dei nodi che ho usato..

    Grazie mille in anticipo

    Elena

     

     

    Harvester
    Moderatore
    @harvester
    #868702

    Ciao Elena. Potresti installare una versione più recente di Blender, stai usando la 3.0.0 e siamo alla 3.1.2 con in arrivo la 3.2.

    Puoi provare a disconnettere la normal map dai nodi Diffuse e Glossy?

    Ti succede anche quando passi alla visualizzazione Rendered (il terzo pallino da sinistra)?

    Come mai non hai collegato il vettore in uscita dal nodo Mapping anche alle altre immagini? Se si tratta di un set di immagini PBR (albedo, roughness, normal) dovresti passargli lo stesso vettore di mappatura.

    Potresti usare un nodo Principled BSDF invece di quella combinazione Diffuse + Glossy (manca il fattore Fresnel e l’influenza della Roughness su di esso, in sostanza non è il modo corretto di combinare i due nodi Diffuse + Glossy)?

    Poiché nella vista Preview (il secondo pallino) stai in pratica usando Eevee, mi domando se con tutti gli oggetti e relativi materiali nella scena tu possa aver raggiunto un limite nel numero di immagini che possono venire visualizzate nella vista 3D.

    Sto tirando ad indovinare con le informazioni e l’immagine fornita.

    elena01
    Partecipante
    • Blenderista
    • Post sul Forum 7
    @elenatrombetta
    #868713

    Ciao! grazie per la tua risposta

    Ho provveduto ad aggiornare Blender con la versione più recente.

    Ho scollegato la Normal Map dai nodi Diffuse e Glossy ma nulla…

    Ho collegato il vettore in uscita dal nodo Mapping anche alle altre due immagini ma non è cambiato nulla

    Ho seguito passo passo la lezione di Francesco Andresciani (allego lo screen di riferimento per vedere i nodi che ha utilizzato)

    E’ strano che non funzioni…

    Scusa per questa domanda ma non sono ancora pratica nell’usare i nodi ma… se utilizzo il nodo Principed BSDF invece che Diffuse+Glossy : elimino il nodo Mix shader, il principed BSDF lo collego al “surface” del Material Output? il nodo dell’Image Texture tramite “Color” al “Base Color” del Principed BSDF e poi.. ColorRamp e Normal Map a cosa di Principed BSDF

     

    Grazie in anticipo

     

    Harvester
    Moderatore
    @harvester
    #868714

    Non saprei come aiutarti per risolvere il problema che stai riscontrando, non ho trovato bug report specifici non risolti nel bug tracker degli sviluppatori. Potresti effettivamente aver raggiunto un limite nel numero di texture immagine. Per verificarlo rimuovi qualche oggetto e relative mappe, o cancellane una o più, quindi salva e riapri il file. Se si risolve allora il problema è questo, troppe mappe immagine, altrimenti sono a corto di suggerimenti.

    Il colore o albedo va nel input denominato Color nel Principled BSDF, la color ramp invece, osserva bene dove la collega nell’immagine che hai postato. La risposta è lì, davanti ai tuoi occhi. La mappa delle normali … indovina?

     

    Per farti un’idea più chiara di come funziona il nodo Principled BSDF ti rimando alla lettura del manuale di Blender: https://docs.blender.org/manual/en/3.1/render/shader_nodes/shader/principled.html

     

    Per capire che cosa sono queste “mappe” (color/albedo, roughness, normal ecc.) nel contesto di un materiale cosiddetto PBR (Physically Based Rendering) ti rimando a queste discussioni e link: https://www.blender.it/forums/topic/physically-based-rendering-in-cycles-riferimenti-bibliografici

     

    tra cui questo link che trovi anche elencato nella discussione di cui sopra: https://substance3d.adobe.com/tutorials/courses/the-pbr-guide-part-2

     

    Altra documentazione o risorse utili le puoi trovare in questa pagina su questo sito web: https://www.blender.it/link-utili

     

    In sintesi, questa è una tipica configurazione per il nodo Principled BSDF: https://www.blender.it/forums/topic/problema-con-trasparenze-di-capelli-daz-studio#post-774340

     

    Buona serata.

     

    andcamp
    Moderatore
    @andcamp
    #868719

    @elenatrombetta carica qui il file .blend che ci siamo un’occhiata

    ajiijf iasfiojsaiojf
    Partecipante
    @nn81
    #868720

    ciao, hai il nodo image texture del colore settato su “clip” anzichè sul “repeat” di default

    elena01
    Partecipante
    • Blenderista
    • Post sul Forum 7
    @elenatrombetta
    #868721

    @nn81 

    GRAZIE MILLE! Era proprio questo il problema… grazie mille ancoraa

    elena01
    Partecipante
    • Blenderista
    • Post sul Forum 7
    @elenatrombetta
    #868722

    Grazie mille a tutti

    fenix
    Partecipante
    @fenix64
    #868733

    Elena procurati beta quad non produce non grandi e divide meglio la mesh

     

    fenix
    Partecipante
    @fenix64
    #868734

    ngon *

Stai visualizzando 10 post - dal 1 a 10 (di 10 totali)
  • Devi essere connesso per rispondere a questo topic.