[Supporto richiesto] Problema importazione modello da sketchup

Blender.it | Supporto Utenti | Supporto Modellazione, modificatori e strumenti | Problema importazione modello da sketchup

Stai vedendo 7 articoli - dal 1 a 7 (di 7 totali)
  • Autore
    Articoli
  • #581131

    Matteo
    Partecipante
    • Blenderista
    • Conversazioni totali14

    Buonasera,

    Dovrei realizzare un fotoinserimento di una tettoia solamente che non essendo molto pratico di Blender ho deciso di modellare con Sketchup ed utilizzare Blender per calibrare la camera, mettendo in prospettiva la foto per un successivo rendering.

    Ora, una volta che ho calibrato la camera di Blender con Blam, creato ed esportato il mio modello con Sketchup in formato .dae decido di importarlo su Blender in modo da posizionarlo sulla foto e successivamente renderizzare.

    Il problema però è il seguente, quando importo il modello in Blender è come se fosse bloccato, i bordi dell’oggetto sono rossi e non posso spostarlo, scalarlo, cancellarlo o qualsiasi altra azione di editing.

    Quando invece però provo ad importarlo su un file vergine di blender posso fare qualunque cosa.

    Qualcuno sa dirmi gentilmente come risolvere il problema permettendomi di importare il modello già creato con sketchup per poi renderizzare?

    Grazie a chiunque voglia darmi una mano. (La versione di blender che utilizzo è la 2.79)

    #581150

    andcamp
    Partecipante
    • Veterano Platino
    • ★★★★★★
    • Conversazioni totali5611
    • Blender.it Staff
    • Associato Blender Italia
    • Moderatore Forum

    Buondì, i bordi rossi potrebbero significare varie cose: seams dell’UV mapping, segni del crease etc. Però però per il modello bloccato al momento non mi viene in mente, bisognerebbe vedere il file


    #581206

    Matteo
    Partecipante
    • Blenderista
    • Conversazioni totali14

    Diciamo che il problema che ho postato l’ho risolto in modo abbastanza semplice, ho riesportato il modello e l’ho ricaricato in un altro file, non so perchè ma adesso funziona!

    Purtroppo mi è sorto un altro problema (a cui non avevo pensato, o meglio, avevo sottovalutato), quando importo il modello e tento di sovrapporlo alla foto le proporzioni della dimensione del modello non tornano con le dimensioni della foto. Premetto che chiaramente il modello è disegnato nelle dimensioni reali e quindi in scala, e anche la camera della foto è calibrata correttamente (formato foto 1920 x 1080, come la camera di Blender).

    Non saprei come risolvere il problema, lo scalo, lo sposto sull’asse X, Y, Z ma il risultato non cambia, le proporzioni non tornano… o mi esce troppo grande o troppo piccolo!

    Suggerimenti?

    #581327

    Alessandro Passariello
    Partecipante
    • Veterano
    • ★★
    • Conversazioni totali610
    • Blender.it Staff
    • Associato Blender Italia
    • Moderatore Forum

    Ti consiglio di usare Blam… farà al caso tuo

    https://github.com/stuffmatic/blam


    Presidente Associazione Blender Italia

    http://www.associazione.blender.it

    #581328

    Alessandro Passariello
    Partecipante
    • Veterano
    • ★★
    • Conversazioni totali610
    • Blender.it Staff
    • Associato Blender Italia
    • Moderatore Forum

    Dal minuto 11:44

    https://www.youtube.com/watch?v=yeC7snRytc8


    Presidente Associazione Blender Italia

    http://www.associazione.blender.it

    #581332

    andcamp
    Partecipante
    • Veterano Platino
    • ★★★★★★
    • Conversazioni totali5611
    • Blender.it Staff
    • Associato Blender Italia
    • Moderatore Forum

    ha scritto che ha usato BLAM


    #581340

    Matteo
    Partecipante
    • Blenderista
    • Conversazioni totali14

    Esatto, Blam l’ho utilizzato per aggiustare la visuale prospettica della foto, infatti se faccio un prova e disegno per esempio una geometria semplice come per esempio un rettangolo le linee seguono perfettamente il mio fabbricato.

    Il problema è che le dimensioni del modello (che ho disegnato in scala con sketchup) non tornano con le dimensioni della foto e mi chiedevo come fare per far tornare il tutto…

    Stasera posto una foto per meglio rendere l’idea, mi rendo conto che così diventa difficile aiutarmi.

Stai vedendo 7 articoli - dal 1 a 7 (di 7 totali)

Devi essere loggato per rispondere a questa discussione.