[Risolto] Problema rendering gpu

Stai vedendo 8 articoli - dal 1 a 8 (di 8 totali)
  • Autore
    Articoli
  • #541498

    Maxstei
    Partecipante
    • Blenderista
    • Post sul forum 8

    Salve a tutti, ho un problema con la GPU (msi radeon hd 7870 2gb oc edition), praticamente in alcune scene che renderizzo si formano delle parte nere, che non vengono mostrate se renderizzo la stessa scena con una xfx rx 480.

    Immagine per capire come appare:

     

     

    Da cosa potrebbe essere causato? Dalla quantità di VRam troppo bassa?

    0
    #541502

    Maxstei
    Partecipante
    • Blenderista
    • Post sul forum 8

    http://oi65.tinypic.com/90xg0l.jpg

    Link all’immagine se non si vede quella sopra.

    0
    #541510

    andcamp
    Moderatore
    • Veterano Platino
    • ★★★★★★
    • Post sul forum 5475
    • Blender.it Staff
    • Associato Blender Italia

    Ciao,  carica qui le immagini, con l’apposita funzione del form, altrimenti tra un po’ andrà tutto perduto
    Potrebbe essere un diverso supporto all’OpenCL? Prova ad aggiornare i drivers della scheda che dà problemi


    0
    #541515

    Maxstei
    Partecipante
    • Blenderista
    • Post sul forum 8

    Inizialmente non mi mostrava l’openCL nel system in user preferences, così ho aggiunto la variabile d’ambiente “CYCLES_OPENCL_SPLIT_KERNEL_TEST=1”.

    I driver sono gli ultimi rilasciati dalla AMD, potrei provare a reinstallare i driver vecchi?

    0
    #541520

    Hullo
    Partecipante
    • Blenderista
    • Post sul forum 351

    Inizialmente non mi mostrava l’openCL nel system in user preferences, così ho aggiunto la variabile d’ambiente “CYCLES_OPENCL_SPLIT_KERNEL_TEST=1”.

    I driver sono gli ultimi rilasciati dalla AMD, potrei provare a reinstallare i driver vecchi?

    Potresti dirmi dove va inserita la variabile???

    0
    #541521

    Maxstei
    Partecipante
    • Blenderista
    • Post sul forum 8

    Pannello di controllo\Sistema e sicurezza\Sistema \ impostazioni di sistema avanzate \  Variabili d’ambiente \

    Premere nuova  in “Variabili di sistema” ed inserire in “Nome Variabile” e “Valore variabile” la stringa sopra.

    Proverò a reinstallare qualche vecchio driver, se qualcun’altro ha idee, sarebbero ben accette.

    0
    #541564

    Maxstei
    Partecipante
    • Blenderista
    • Post sul forum 8

    Non ho ancora risolto, ma per evitare di usare la CPU per renderizzare ed aspettare 3 minuti a frame, ho impostato la GPU come principale e il processore come secondario, in modo da diminuire il tempo di rendering ed evitare artefatti nell’immagine, infatti adesso ci impiega in media dai 55 secondi al minuto e 7 secondi!

    0
    #541620

    Maxstei
    Partecipante
    • Blenderista
    • Post sul forum 8

    Problema risolto! La mia scheda video ha un’archittetura GCN 1.0, e blender ha tolto la compatibilità dalla versione 2.78c in poi, quindi è bastato installare una versione precedente ed è tutto funzionante perfettamente. Il render time è passato a 30 secondi contro i 3 minuti emmezzo della CPU.

    0
Stai vedendo 8 articoli - dal 1 a 8 (di 8 totali)

Devi essere loggato per rispondere a questa discussione.