Problema spostamento vertici…

Stai vedendo 8 articoli - dal 1 a 8 (di 8 totali)
  • Autore
    Articoli
  • #15888

    ccddxxff
    Partecipante
    • Blenderista
    • Post sul Forum 103

    hello a tutti,

    durante il runtime del gioco sposto in asse z i vertici di un piano suddiviso in più quadrati e questo funziona. Ora, su di esso faccio puntare un empty dotato di sensore ray e imposto la posizione di un cubo alla hitPosition del ray che interseca il piano. Ora, se il piano è tutto “piano”, cioè non ci sono dislivelli, lo spostamento del cubo è ovviamente planare. Ma se sposto anlcuni vertici sull’asse z cercando di formare una sorta di montagnetta, il cubo invece che salire sulla montagnetta (conseguenza del .hitPosition del ray), prosegue in direzione planare passandoci sotto, come se in realtà  la montagna non esistesse…. attivandoo il show psysics visualization mi accorgo che al plane, ricoperto da linee verdi che delimitano le facce che lo compongono, quando vado ad alzare o abbassare alncuni vertici, essi si alzano o abbassano effettivamente, ma le linee verdi rumangono esattamente come prima, PLANARI!!! come mai ??

    non so se sono stato chiaro 😳

    #181506

    Qwerty
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 456

    … non ti seguo. 😕

    Puoi postare alcune immagini o, meglio ancora, il file?

    #181507

    ccddxxff
    Partecipante
    • Blenderista
    • Post sul Forum 103

    [youtube]http://www.youtube.com/watch?v=LSvOSroOtls[/youtube]

    come mostra il fimato, la freccia blu invece che SALIRE sulle facce oblique, passa sotto continuando il suo percorso come se in realtà  le facce oblique non esistessero … spero che sia chiaro 😳

    #181508

    GiganteBaba
    Partecipante
    • Blenderista
    • Post sul Forum 122

    è veramente difficile aiutarti… La cosa più stupida che mi viene in mente è chiederti che tipo di bounds sono impostati, magari dipende da li..

    #181509

    ccddxxff
    Partecipante
    • Blenderista
    • Post sul Forum 103

    nessuno, ma li ho provati tutti … anche settando il compound …

    ma come mai c’è questo problema? Se le facce le rendo oblique prima di avviare il gioco, tutto funziona, ma se le rendo oblique durante, niente ….

    #181510

    GiganteBaba
    Partecipante
    • Blenderista
    • Post sul Forum 122
    ccddxxff wrote:
    Se le facce le rendo oblique prima di avviare il gioco, tutto funziona, ma se le rendo oblique durante, niente ….

    Dovresti tenere conto quindi che potrebbe essere un bug di blender. Comunque forse esiste un qualche comando per resettare la fisica, magari in questo modo ricalcola il tutto… Altrimenti forse conviene cambiare totalmente strategia della posizione della freccia o del cubo, magari usando le info delle coordinate Z dei vertici.

    Buona fortuna!

    #181511

    ccddxxff
    Partecipante
    • Blenderista
    • Post sul Forum 103

    grazie per aver risposto GiganteBaba … sto vedendo qualche reset per la fisica.

    Quote:
    … magari usando le info delle coordinate Z dei vertici.

    ci avevo già  provato ed effittivamente funziona solo che il ray deve passare sempre sotto, se passo da sopra alla faccia, la freccia va una delle facce dietrò perchè giustamente l’intera mesh fisicamente è piana…

    cmq grazie 😉

    #181512

    LeleDaRevine
    Partecipante
    • Veterano Argento
    • ★★★★
    • Post sul Forum 3308

    In pratica hai creato un editor di terreni! Ganzo! 😀

    Però non so aiutarti più di quello che han già  fatto. 😐

Stai vedendo 8 articoli - dal 1 a 8 (di 8 totali)

Devi essere loggato per rispondere a questa discussione.