[Supporto richiesto] Problema texture (2.79)

Stai vedendo 11 articoli - dal 1 a 11 (di 11 totali)
  • Autore
    Articoli
  • #749075

    Ricky135
    Partecipante
    • Blenderista
    • Post sul Forum 7

    Ciao a tutti, sono alle prime armi con blender e sto avendo dei problemi con le texture…..come potete vedere dalla foto sotto, quando applico la texture mi appaiono quelle due linee di stacco evidenziate: la n°1 è in corrispondenza della divisione delle facce, mentre la seconda sinceramente non ho idea da cosa sia dovuta, visto che lì non c’è nessun “edge loop”.

    Per informazione, il mesh è stato creato da un piano, reso poi tridimensionale con il modificatore “solidify”, in seguito ho applicato anche il “subdivision surface”.

    Per applicare la texture ho aggiunto il nodo “image texture” e poi ho selezionato “smart UV project”.

    Sapete aiutarmi? Grazie!

    #749076

    waaf
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 596
    • Associato Blender Italia

    Devi fare l’ UVunwrap in altra maniera. Quelli sono i bordi dell’ imagine quando si ripete

    #749078

    pix di chito
    Partecipante
    • Blender.it Staff
    • Associato Blender Italia
    • Professionista accreditato
    • Moderatore Forum

    a occhio e croce i problemi potrebbero essere due: texture non “seamless” (cioè si crea un effetto “cucitura” dove la texture finisce) oppure, come già suggerito da waaf, un problema di unwrap; credo il problema sia il primo perchè vedo parecchi “tagli” nel materiale


    architetto freelance – CG artist – art director & 3d artist presso VidaSystems
    #749135

    Ricky135
    Partecipante
    • Blenderista
    • Post sul Forum 7

    Quindi sarebbe meglio prendere una texture più uniforme per non vedere quei tagli giusto? e per l’ UVunwrap consigliate di modificarlo manualmente?

    un’altra cosa: qual è il metodo per “girare” la texture? ovvero le “righette” della texture vorrei che fossero nella direzione opposta…

    #749138

    waaf
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 596
    • Associato Blender Italia

    devi fare l’ UVunwrap a mano.

    #749171

    Anfeo
    Membro
    • Blender.it Staff
    • Associato Blender Italia
    • Professionista accreditato
    • Moderatore Forum

    Spiego una procedura molto più semplice in questo mio tutorial senza dover usare le UV:

    In pratica imposti come Object il tipo di mappatura su Geometry e poi nelle opzioni del nodo Image imposti come Box, quindi aumenti il valore Blend e in questo modo ti sfuma i bordi della texture


    #749176

    Akenaton
    Partecipante
    • Blenderista
    • Post sul Forum 352
    • Associato Blender Italia

    Uso spesso la procedura suggerita da Anfeo, ma avrei una piccola domanda:

    posso mixare la mappatura object con quella Uv?

    Mi spiego meglio:

    Sto modellando il carro armato per il contest di questo mese e il materiale sarà fatto con la procedura descritta da Anfeo; ma quando dovrò poi applicare numeri, loghi, serie e quant’altro mi sa che dovrò per forza fare Uv Map per posizionarli in determinati punti. Posso poi mixarli insieme?

    #749177

    Harvester
    Partecipante
    • Veterano Bronzo
    • ★★★
    • Post sul Forum 2744
    • Blender.it Staff
    • Associato Blender Italia
    • Moderatore Forum

    Certamente, creando delle mappe UV specifiche da utilizzare come coordinate per le decalcomanie.

    #749235

    Ricky135
    Partecipante
    • Blenderista
    • Post sul Forum 7

    Ho provato il metodo di Anfeo e lasciando “Flat” la texture viene applicata correttamente, ma ovviamente non viene visualizzata sullo spessore dell’oggetto, cambiando in “box” però mi rimangono dei punti in cui la texture è girata rispetto al resto, come si vede dalla foto:

    a cosa è dovuto? scusate ma sono proprio all’inizio

    #749238

    Akenaton
    Partecipante
    • Blenderista
    • Post sul Forum 352
    • Associato Blender Italia

    L’input è su object”?

     

    #749239

    Ricky135
    Partecipante
    • Blenderista
    • Post sul Forum 7

    sì è su object

Stai vedendo 11 articoli - dal 1 a 11 (di 11 totali)

Devi essere loggato per rispondere a questa discussione.