[Supporto richiesto] Problema Unwrap

Stai vedendo 9 articoli - dal 1 a 9 (di 9 totali)
  • Autore
    Articoli
  • #558512

    Travereticolare
    Partecipante
    • Blenderista
    • Post sul Forum 17

    Buonasera,

    Sto cercando di prendere un po’ di confidenza con Blender  e più precisamente con i materiali, texture e rendering per un lavoro di architettura che dovrò portare a termine in futuro, al riguardo ho già aperto una discussione, solamente che prima di eseguire il lavoro vorrei esercitarmi un po’ con i materiali ed il rendering.

    L’esercizio che mi sono proposto stasera è di modellare il pezzo più importante degli scacchi e cioè il Re, con la modellazione nessun problema ma come al solito quando devo assegnare i materiali  vengono i problemi. Ho deciso di assegnare una texture marmorea (dimensione foto 2000 x 1333) al mio pezzo, facendo l’unwrap del materiale. Il problema come desumibile dalla foto allegata e che nella parte bassa del pezzo ho una ripetizione della texture, sembrerebbe quasi che l’immagine segue le singole superfici che si sono venute a creare nella modellazione del pezzo. Qualcuno potrebbe dirmi come ovviare il problema? proprio non riesco a capire come fare…

    Ringraziando chiunque abbia voglia di darmi una mano, auguro Buona Serata!

     

    #558517

    andcamp
    Partecipante
    • Veterano Platino
    • ★★★★★★
    • Post sul Forum 5740
    • Blender.it Staff
    • Associato Blender Italia
    • Moderatore Forum

    ciao, però così è bellissima, non cambiarla 😀

     

    Modifica nel nodo texture da “repeat” a “clip”

     

    Ma se sei arrivato a quel problema vuol dire che non hai seguito la strada giusta, cioè usare correttamente l’uvmapping, tracciando prima i seams (per la parte bassa come un cilindro, come un parallelepipedo dove c’è la croce)


    #558520

    Travereticolare
    Partecipante
    • Blenderista
    • Post sul Forum 17

    ciao, però così è bellissima, non cambiarla 😀

    Ho tenuto una copia per ricordarmi del mio errore, in modo da non ripeterlo più in futuro 😀

    Modifica nel nodo texture da “repeat” a “clip”

    avevo provato anche io a smanettare ma non cambiava nulla…

    Mi sa che avevo fatto proprio un errore da novellino però (il quale sono) in pratica avevo fatto l’unwrap senza sviluppare la mappa UV. Ti dico la strada che ho seguito così mi magari mi dici se ho fatto bene oppure no;

    Dopo aver inserito la texture, ho selezionato tutto il modello in edit mode poi ho schiacciato la lettura “U” e successivamente ho selezionato “Smart UV project”  e successivamente ho renderizzato. Il tutorial che ho visto diceva che era il metodo più veloce per farlo, ma anche il più pigro :). Domani magari cerco di imparare il metodo normale, in modo da saperli usare entrambi in caso di bisogno (sempre che riesca a trovare quale sia l’altro metodo…).

    Questo è il risultato che ho ottenuto:

    #558522

    little_angel
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 905
    • Associato Blender Italia

    stavo per rispondere prima, poi c’ho rinunciato, ora c’ho ripensato XD

    per prima cosa prima di procedere ad un unwrap io di solito mi “paro il popò” verificando per l’Nsima volta  il “remove doubles” (perchè sono un pasticcione quando modello ^^) e ricalcolando le normali, quindi in base a quel che devo/voglio fare mi regolo di conseguenza sul tipo di unwrap da seguire, ce ne sono tanti di modi e molti possono andare tranquillamente a gusto, non neccessariamente sei obbligato a usare le “cuciture” anche se il più delle volte offrono un workflow meglio organizzato. consiglio, parti con una mesh semplice e texture semplice e facci due esperimenti sui vari tipi di unwrap così cominci a capire come funzionano, e in base alla tua esperienza poi scegli quello che più ti garba


    e allora.. sotto!!
    #558525

    andcamp
    Partecipante
    • Veterano Platino
    • ★★★★★★
    • Post sul Forum 5740
    • Blender.it Staff
    • Associato Blender Italia
    • Moderatore Forum

    |Dopo aver inserito la texture, ho selezionato tutto il modello in edit mode poi ho schiacciato la lettura “U” e successivamente ho selezionato “Smart UV project”  e successivamente ho renderizzato.

     

    tieni conto che però ora sono visibili delle cuciture sul davanti-destra. Forse dovresti sistemare un po’


    #558530

    Travereticolare
    Partecipante
    • Blenderista
    • Post sul Forum 17

    Me ne sono accorto, solo che non so come fare per toglierla…

    #558534

    little_angel
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 905
    • Associato Blender Italia

    @matteo seleziona il loop di vertici interessato, quindi fai ctrl+e -> “clear seam”


    e allora.. sotto!!
    #558563

    Travereticolare
    Partecipante
    • Blenderista
    • Post sul Forum 17

    Con la combinazione di tasti “shift + alt e click desto sul vertice ho selezionato tutta la linea dove si vede la cucitura, successivamente ho fatto ctrl+e -> “clear seam” ma la situazione non cambiava (magari sbaglio qualche passaggio, ma non capisco dove). Ho quindi sperimentato un altro metodo, in pratica per la parte bassa ho fatto U –> “Cylinder Projection”, mentre per la parte alta ho fatto invece fatto “Smart UV project”. Ho fatto quindi due tipi di proiezione, ed il risultato è questo in foto

    #558566

    little_angel
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 905
    • Associato Blender Italia

    se ben ricordo una volta che rimuovi la cucitura dovresti rifare l’unwrap, la cucitura serve “solo” a far si che quando unwrappi una mesh con delle cuciture presenti lei ti sbucci/scarti il tutto seguendo quelle linee ideali, faccio l’esembio di un giubbotto modello “bomber all’americana” dove le braccia sono differenti dal resto, dovendo unwrappare un modello del genere farei 2 seams in corrispondenza dell’attacco alle ascelle, poi due che partono dalle ascelle fino alle maniche, in modo da srotolarle letteralmente per applicarvi una texture differente da quella del resto del giubbotto.

    è difficile così su due piedi consigliarti anche perchè non hai messo una foto della texture intiera per capire, così a occhio, se risulta applicata correttamente in base ai render che stai postando.. secondo comè potrebbe bastare anche fare 2 inquadrature con camera orto, frontale e posteriore e 2 rispettivi unwrap di tipo “bound from view” richiamando la stessa immagine senza toccare praticamente nulla XD

    consiglio: quando fai l’unwrap, tirati una finestra per l’UV mapping, nell’altra lascia la 3dview in modalità “rendered” per gli objects (anzichè la solid di default) così hai un riscontro in tempo reale delle manovre su uv-map (confido che tu sappia muoverti nell uv map, scalando ruotando spostando anche i singoli vertici per un unwrap manuale..), chiaramente se la scena è pesante per un simil lavoro impostati i vari settaggi al minimo per offrirti un render veloce, tipo samples a 1 per illuminazione, AO disattivato, insomma le cose che ciucciano più risorse


    e allora.. sotto!!
Stai vedendo 9 articoli - dal 1 a 9 (di 9 totali)

Devi essere loggato per rispondere a questa discussione.