python 2.6.2

Stai vedendo 25 articoli - dal 1 a 25 (di 27 totali)
  • Autore
    Articoli
  • #15481

    Gaber
    Partecipante
    • Blenderista
    • Post sul forum 12

    ciao!sono nuova!ho un piccolo problema,che credo sia stato già  trattato,ma che non riesco a risolvere!

    😥 dunque ho installato blender 2.49 che mi richiede python 2.6.2 l’ho installato,disinstallato mille volte ma ogni volta che apro blender mi dice di installarlo!(ho windows 7 64bit),come se non avessi fatto nulla!ne ho assoluto bisogno x trasportare i file sketchup e renderizzare per un esame nei prossimi giorni…vi prego help me!avete una soluzione?


    #178661

    {Genesis}
    Partecipante
    • Veterano
    • ★★
    • Post sul forum 529

    Inizio col dirti che l’assenza Python non influisce minimamente sull’usabilità  di blender, per dirla in maniera facile Blender funziona benissimo anche senza, sebbene in quel caso non si possano usare gli script.

    Venendo al tuo problema, sei sicuro che non ti veda Python? E’ piuttosto strano ti invito quindi a scrivere che cosa dice la console.


    #178662

    ortogonale59
    Partecipante
    • Blenderista
    • Post sul forum 90

    Blender e python sono entrambi a 64 o 32 bit?

    In caso contrario spesso la cosa non funziona.

    Per verificare se hai installato correttamente python: lancia un terminale (Tasto windows+R e poi scrivi cmd) da li prova a digitare python.

    Se ti compare una scritta con la versione ed il prompt >>> lo hai installato correttamente. Altrimenti disinstalla, verifica le versioni e reinstalla.


    #178663

    Gaber
    Partecipante
    • Blenderista
    • Post sul forum 12

    Se ti compare una scritta con la versione ed il prompt >>> lo hai installato correttamente….hai ragione l’ho installato correttamente e allora perchè quando apro blender nella schermata nera appare:COMPILED WHIT PYTHON VERSION 2.6.2

    CHECKING FOR INSTALLED PYTHON…GOT IT!

    continuo a provare a importare file collada ma mi da errore python!

    quando provo a importare questi file la consol dice

    import error:DLL load failed 1% non (simbolo)un’applicazione di windows32 valida

    può servire???


    #178664

    {Genesis}
    Partecipante
    • Veterano
    • ★★
    • Post sul forum 529

    Ehm! got it! significa che lo ha trovato!!!

    La scritta nel terminale:

    Compiled with Python ….

    Ti indica fondamentalmente quale versione installare nel sistema. 😉

    Per l’errore in importazione non dice nulla nella console? Errore Python e’ piuttosto generico.


    #178665

    Gaber
    Partecipante
    • Blenderista
    • Post sul forum 12

    leggi su ho modificato…! :mrgreen:


    #178666

    Gaber
    Partecipante
    • Blenderista
    • Post sul forum 12

    continuo a provare a importare file collada ma mi da errore python!

    quando provo a importare questi file la consol dice

    import error:DLL load failed 1% non (simbolo)un’applicazione di windows32 valida


    #178667

    {Genesis}
    Partecipante
    • Veterano
    • ★★
    • Post sul forum 529

    Mmmm?! O_o sembra si lamenti di una chiamata di una dll (una libreria dinamica) che farebbe riferimento ad un’altra applicazione.

    Purtroppo in questo caso non posso esserti di aiuto, ora come ora non ho a portata di mano ne un file collada ne tanto meno un PC con win7, mi spiace.

    Intanto vediamo se qualcun altro può esserti di aiuto.


    #178668

    Wolvy
    Partecipante
    • Veterano
    • ★★
    • Post sul forum 414
    ortogonale59 wrote:
    Blender e python sono entrambi a 64 o 32 bit?

    In caso contrario spesso la cosa non funziona.

    Per verificare se hai installato correttamente python: lancia un terminale (Tasto windows+R e poi scrivi cmd) da li prova a digitare python.

    Se ti compare una scritta con la versione ed il prompt >>> lo hai installato correttamente. Altrimenti disinstalla, verifica le versioni e reinstalla.

    Ho provato anch’io questo test,

    ma bisogna entrare nelle directory di installazione di Python

    perché il comando “python” venga riconosciuto!!!


    #178669

    Gaber
    Partecipante
    • Blenderista
    • Post sul forum 12

    scusami non ti seguo… 🙄


    #178670

    Wolvy
    Partecipante
    • Veterano
    • ★★
    • Post sul forum 414

    Nel senso che avviando il prompt dos, se scrivo il comando Python

    dalla directory in cui mi si apre non funziona, esempio:

    Code:
    C:UserPincoPallino>python
    “python” non è riconosciuto come comando interno o esterno….. etc etc

    Mentre, digitando il comando dalla directory di installazione di Python,

    il comando python funziona, cioè esegue Python.

    Code:
    C:Python26>python

    #178671

    Gaber
    Partecipante
    • Blenderista
    • Post sul forum 12

    cmq python in teoria dovrebbe andare…è solo quando importo questi file collada(dae)…che mi dà  errore…

    cmq grazie…siete gentili


    #178672

    ortogonale59
    Partecipante
    • Blenderista
    • Post sul forum 90

    Se python non si avvia dal prompt del DOS vuol dire che non e’ nel path. Basta aggiungerlo da pannello di controllo.

    Per i file collada, che dovrebbero essere standard, bisogna vedere da quale programma sono stati generati, perche’ anche a me qualche volta alcuni non si importano

    Oppure succede che Blender 2.49 non li carica ma la versione 2.5.x si’… ❓

    Un’occhiata a questo link potrebbe tornare utile:

    https://collada.org/mediawiki/index.php … nge_Schema

    Non avevo letto bene: importi da SketckUp. Quale versione? Io ho la 7.1.6860 e Blender 2.49b importa con Collada1.4 ma non con la 1.3.1, mentre Blender 2.5.2 non ha alcun problema.


    #178673

    Wolvy
    Partecipante
    • Veterano
    • ★★
    • Post sul forum 414
    ortogonale59 wrote:
    Se python non si avvia dal prompt del DOS vuol dire che non e’ nel path. Basta aggiungerlo da pannello di controllo.

    E’ grave!? cioè incide sul corretto funzionamento?

    Come si aggiunge da Pannello di Controllo?


    #178674

    ortogonale59
    Partecipante
    • Blenderista
    • Post sul forum 90

    No, non e’ grave anche perche’ se Blender te lo vede non ci sono problemi. Potrebbe essere un po’ noioso se programmi in python perche’ devi scrivere tutto il percorso invece che chiamare l’interprete direttamente. Comunque per aggiungerlo al path (l’esempio e’ fatto su Vista ma vale anche per XP e per 7 a parte le piccole varianti introdotte da Microsoft da un sistema all’altro) fai cosi’:

    Pannello di controllo poi Sistema quindi “Impostazioni di sistema avanzate” (in Vista sono nel frame a sinistra, in XP mi pare che questo passaggio non ci sia, in 7 non mi ricordo anche perche’ in questo momento non ce l’ho sotto mano). A questo punto dovresti avere la finestra di ‘Proprieta’ di sistema’, seleziona il tab “Avanzate” e clicca su “Variabili d’ambiente…”

    Nella sezione variabili di sistema nella colonna “Variabile” cerca la voce “Path” quindi doppio click e nel dialogo “Modifica variabile di sistema” aggiungi al fondo di “Valore variabile” questo “;C:Python26” (senza i doppi apici e non dimenticare il ;(punto e virgola)) che e’ il percorso dove e’ stato installato python. Cambia lettera del drive o percorso se e’ stato installato in altra posizione diversa da quella standard. Attenzione a non alterare il resto della stringa path altrimenti poi non funzionano piu’ un sacco di cose!!!! Salva e riavvia. Ora dovresti essere in grado di richiamare python da qualunque cartella.


    #178675

    Wolvy
    Partecipante
    • Veterano
    • ★★
    • Post sul forum 414

    Ok, grazie mille, molto gentile.

    Un dubbio! Avendo installato sia Python26 che Python31

    se aggiungo entrambe le stringhe cioè “;C:Python26” e “;C:Python31”

    quando lancio Python, quale mi avvia!? Potrebbero entrare in conflitto?

    Per ora ho aggiunto solo la stringa “;C:Python26”.


    #178676

    ortogonale59
    Partecipante
    • Blenderista
    • Post sul forum 90

    Se hai entrambe le versioni installate aggiungi solo il path di quella che usi perche’ si va a rischio di conflitti. Comunque il sistema scandisce il path e utilizza (o almeno dovrebbe) cio’ che trova per primo. Se, ad esempio, hai il %PATH%;C:Python26;C:Python31 windows cerchera’ di avviare il python 2.6 e cio’ non e’ detto che sia sempre quello che vuoi.

    Usando solo python con blender quest’ultimo e’ in grado di trovarselo da solo, se installato nelle posizioni di default e quindi il path non ti serve a molto…


    #178677

    Gaber
    Partecipante
    • Blenderista
    • Post sul forum 12

    e si anch’io ho la versione 7di sketchup…e ho blender 2.49!tutto installato correttamente ma non riesco a importare file collada in nessun modo…continua a dirmi quello che ho scritto sopra!


    #178678

    {Genesis}
    Partecipante
    • Veterano
    • ★★
    • Post sul forum 529

    Che versione di collada esporti? ti ricordo che:

    ortogonale59 wrote:
    …Non avevo letto bene: importi da SketckUp. Quale versione? Io ho la 7.1.6860 e Blender 2.49b importa con Collada1.4 ma non con la 1.3.1, mentre Blender 2.5.2 non ha alcun problema.

    #178679

    Gaber
    Partecipante
    • Blenderista
    • Post sul forum 12

    1.4 certo…. ma nn vaAA!!!!!!!!!!!!!!!


    #178680

    Gaber
    Partecipante
    • Blenderista
    • Post sul forum 12

    devo installare un altra versione di blender?che importi file collada da sketchup!qualcuno sà  una qualsiasi soluzione pur di riuscire a portare sti file in blender??………..grazie………

    gabry


    #178681

    {Genesis}
    Partecipante
    • Veterano
    • ★★
    • Post sul forum 529

    A questo punto missa che ti tocca davvero mettere la 2.5 di blender, io non ho più consigli da darti, non ho mai incontrato tutti questi problemi XD


    #178682

    ortogonale59
    Partecipante
    • Blenderista
    • Post sul forum 90

    prova a fare queste cose:

    verifica se l’importer qui presente funziona installandolo al posto di quello presente in blender: http://www.blendernation.com/blender-co … -importer/

    Non so se hai installato la versione di blender a 64 bit o quella a 32. Se hai installato la prima, magari prova a rimuoverla ed a installare quella a 32 bit (e anche python a 32 bit).

    Oppure installa anche una versione di blender 2.5.2 dal sito di blender o anche da graphicall.org (se lo vuoi piu’ aggiornato): a me importa collada senza problemi!

    Fammi sapere…


    #178683

    ortogonale59
    Partecipante
    • Blenderista
    • Post sul forum 90

    e aggiungo ancora una cosa:

    se proprio non va, potresti provare a postare un file di collada cosi’ si puo’ provare a vedere se si apre su qualche altra macchina e magari restituirti il .blend.


    #178684

    Gaber
    Partecipante
    • Blenderista
    • Post sul forum 12

    cavolo siete propio dei sapientoni voi!!!io sto programma nn lo capisco tanto…preferisco 3dsmax!ma non posso usarlo per questo esame!cmq adesso le provo tutte e vi faccio sapere! grazieeeeeeeeeeeee

    gabry :mrgreen:


Stai vedendo 25 articoli - dal 1 a 25 (di 27 totali)

Il forum ‘Richiesta di supporto’ è chiuso a nuove discussioni e risposte.