Taggato: ,

Stai visualizzando 20 post - dal 1 a 20 (di 20 totali)
  • Autore
    Post
  • Vittoria
    Partecipante
    • Blenderista
    • Post sul Forum 20
    @c-vitto
    #865205

    Sto riscontrando problemi con il rendering utilizzando la GPU. Quando lancio il render, si apre la schermata, ma non compare nessuna immagine, mentre nella barra in alto il render sembra procedere, dato che vengono conteggiati i secondi e fanno vedere anche gli elementi che vengono caricati.

    Se imposto la CPU, funziona tutto normalmente.

    Grazie a chi risponderà

    HershelLayton95
    Partecipante
    @hershellayton95
    #865208

    Per capire se è un problema di GPU ti consiglio di provare con altre versione di blender lo stesso render.
    Se è questione di file allora prova con un altro file.

    Se in entrambi i casi non funziona prova ripristinare le preferenze di base e reimpostare la GPU.

    Se il problema persiste allora disinstalla il/i driver della gpu e reinstallalo/i dopo averlo/i scaricato/i dal sito della casa produttrice.

    Harvester
    Partecipante
    @harvester
    #865234

    Per prima cosa dovresti contestualizzare questo tipo di richieste di supporto tecnico specificando la versione di Blender che ti sta dando problemi, il sistema operativo della tua macchina, quanta memoria RAM hai, che scheda grafica utilizzi e quanta memoria VRAM ha montata. Questo perlomeno ci permette di capire l’ambiente in cui Blender sta operando.

    Questo problema è apparso all’improvviso mentre prima funzionava tutto correttamente? Il problema si presenta solo con quel file di lavoro oppure con avviene con qualunque altro file che vai a renderizzare? Quanta memoria VRAM viene usata durante il rendering? Puoi riprodurre il problema anche con un file semplificato? Quali sono le impostazioni di rendering della scena? Tutte queste domande servono per cercare di capire dove potrebbe annidarsi la causa di questo problema.

    Il passo successivo è quello di resettare Blender alle impostazioni di fabbrica e verificare se il problema persiste oppure no.

    Vittoria
    Partecipante
    • Blenderista
    • Post sul Forum 20
    @c-vitto
    #865341

    Premesso che non sono molto esperta, comunque a inizio anno ho acquistato un laptop con le seguenti caratteristiche:

    Processore: 11th Gen Intel(R) Core(TM) i7-11800H @ 2.30GHz   2.30 GHz

    RAM: 16 GB

    Scheda video NVIDIA GeForce RTX 3060; VRAM: 128 MB

    Utilizzo sistema operativo windows 11, la versione di Blender è la 2.9. Questo sarebbe il primo progetto che provo a renderizzare, e quindi non posso dire se è un problema che mi si è presentato solo adesso.

    Dopo aver provato a cambiare qualche impostazione, ho visto comparire il messaggio “system is out of GPU and shared host memory”. Ho provato ad abbassare il numero di sample, e sono scesa a 60 samples render per riuscire ad ottenere un’immagine senza questo errore.

    Nella scena conto 5,613,599 vertici

     

    Alfredo
    Partecipante
    @alfredo-2
    #865345

    Il problema è che la VRAM è estremamente esigua: solo 128 MB. Tieni presente che la scena, per essere renderizzata con la GPU, deve essere interamente contenuta nella VRAM. Questo spiega il perché non riesci a renderizzare con la GPU. Tieni presente che col mio notebook, dotato di una scheda NVIDIA con ‘soli’ 2 GB di VRAM, si presenta lo stesso problema anche con scene non troppo complesse. Hai necessità di avere una GPU con almeno 4 GB per scene di complessità media. Ti consiglio una scheda video con 8 GB di VRAM, qualora avessi intenzione di realizzare scene di una certa complessità. In alternativa, renderizza con la sola CPU, che accede a 16 GB di RAM, nella consapevolezza di dover attendere tempi biblici.

    Tieni anche presente che le schede video contenute nei laptop sono depotenziate rispetto a quelle desktop. Ad esempio, una RTX 3070 di un notebook corrisponde a una RTX 3050 di un desktop.

    Spero di esserti stato utile.

     

     

     

    fenix
    Partecipante
    @fenix64
    #865348

    controlla che in preferenze Sistem hai i cuda attivati

    Vittoria
    Partecipante
    • Blenderista
    • Post sul Forum 20
    @c-vitto
    #865356

    In realtà, mi sono accorta che i 128 MB di VRAM si riferivano alla scheda video integrata. Quindi ho paura che sia attiva solo quella.. Non riesco a capirlo, perchè sul pannello di controllo della scheda NVIDIA, ho impostato l’uso del processore ad alte prestazioni sia nelle impostazioni globali, sia nell’uso specifico di blender. Ho fatto la stessa cosa per Blender, dalle impostazioni del pc. Però quando voglio andare a vedere la VRAM della scheda video, ho info solo relativamente a quella integrata, e non so come selezionare quella dedicata…

    Vittoria
    Partecipante
    • Blenderista
    • Post sul Forum 20
    @c-vitto
    #865359

    La VRAM della scheda video dovrebbe essere di 6 GB, ma non viene indicata nelle impostazioni di schermo avanzate.. lascio gli screenshot

    Alfredo
    Partecipante
    @alfredo-2
    #865360

    Segui allora i seguenti passaggi:

    • Vai nel menu Edit di Blender e scegli la voce Preferences…
    • Nella finestra che si apre, seleziona il pannello System
    • Nel sottopannello ‘Cycles Render devices’, fai click o su CUDA o su OptiX
    • Metti il segno di spunta solo su ‘RTX 3060 (Display)’. Ti consiglio di evitare di spuntare anche la CPU Intel i7 perché solitamente il doppio segno di spunta rallenta il processo di rendering
    • Chiudi il pannello e spostati nella ‘Properties Window’
    • Qui, nel pannello ‘Render Properties’, seleziona Cycles come ‘Render Engine’ e, nel menu a discesa Device, sleziona ‘GPU Compute’.
    • Renderizza la scena.
    • Enjoy!

    Di solito OptiX renderizza più velocemente rispetto a CUDA, ma non è una regola generale. Ti consiglio, comunque, di mettere il segno di spunta sulla GPU sia in CUDA sia in OptiX.

     

    Vittoria
    Partecipante
    • Blenderista
    • Post sul Forum 20
    @c-vitto
    #865377

    Avevo già selezionato tutto come mi ha scritto, purtroppo continua a darmi lo stesso problema.

    Harvester
    Partecipante
    @harvester
    #865402

    Se hai fatto tutto quello che è stato sopra descritto, allora è probabilmente un problema di memoria VRAM esaurita visto che se renderizzi con la CPU non hai problemi. In teoria, dovrebbe usare la memoria RAM quando quella Video si esaurisce ma dipende anche da quanta memoria RAM hai libera in quel momento. Per ridurre l’impatto sulla scheda grafica non serve modificare il numero di samples bensì la geometria e le texture che se di grandi dimensioni possono impattare notevolmente sul consumo di memoria Video.

    La prova del nove è facile da fare. Crea una nuova scena in un nuovo file, suddividi il cubo usando anche un modificatore Subdivision Surface e prova per passi successivi a vedere fino a che punto la tua scheda grafica regge il carico all’aumentare della densità della geometria. Quello è il tuo limite di poligoni, memoria VRAM eccetera. Con solo il cubo valuti solo il limite nella dimensione della geometria, ma non l’impatto delle texture sulla memoria.

    Se non puoi ridurre la densità dei poligoni nella scena, puoi eventualmente scomporre la scena in diversi View Layers e renderizzare parti diverse da poi ricomporre tramite il Compositor di Blender. Nel caso puoi dare un’occhiata a questo file di esempio creato con la versione 3.1 di Blender: https://www.blender.it/risorse-condivise/file/view_layers_comp_3-1-blend/

     

    Vittoria
    Partecipante
    • Blenderista
    • Post sul Forum 20
    @c-vitto
    #865407

    Grazie del suggerimento, proverò a fare come mi ha indicato. Grazie a tutti per l’aiuto 🙂

    Pasticciamusica
    Partecipante
    @pasticciamusica
    #865418

    Fai come dice Harvester, anche a me dava lo stesso messaggio quando avevo solo 5.000.000 di vertici, ora sono arrivato a più di 6.000.000 e ancora non ho finito ma scomponendo la scena riesco a fare il render.

    Vittoria
    Partecipante
    • Blenderista
    • Post sul Forum 20
    @c-vitto
    #865431

    Benissimo, seguirò i vostri consigli, e grazie ancora a tutti!

    Alfredo
    Partecipante
    @alfredo-2
    #865734

    La soluzione è quella suggerita da Harvester. Poiché è un problema comune a quanti operano con la grafica 3D e, in particolare, con Blender, ho preparato un tutorial per chi dispone di un computer dotato di una GPU con una modesta quantità di VRAM. Con questa tecnica riesco, ad esempio, a renderizzare qualsiasi scena quando opero in mobilità col mio MacBook Air M1 con soli 8 GB di memoria condivisa (RAM + VRAM).

    Trovi il Tutorial su YouTube al seguente link: https://youtu.be/yU-sy6sRrvg

     

    Harvester
    Partecipante
    @harvester
    #865736

    Ottimo, Alfredo!

    Pasticciamusica
    Partecipante
    @pasticciamusica
    #865738

    Grazie Alfredo, tra te e Harvester mi avete aperto un mondo.

    Alfredo
    Partecipante
    @alfredo-2
    #865762

    Grazie a voi.

    fenix
    Partecipante
    @fenix64
    #865782

    realizzato

    Harvester
    Partecipante
    @harvester
    #865783

    In effetti erano sufficienti due soli render Layer, uno per lo sfondo ed il secondo per la colonna. Hai comunque appreso la tecnica

Stai visualizzando 20 post - dal 1 a 20 (di 20 totali)
  • Devi essere connesso per rispondere a questo topic.