Retopo x Archviz con UE

Blender.it | ArtWork | Work in Progress | Retopo x Archviz con UE

Stai vedendo 12 articoli - dal 1 a 12 (di 12 totali)
  • Autore
    Articoli
  • #491193

    michele vinci
    Partecipante
    • Blenderista
    • Post sul forum 39

    Ciao Blenderisti !
    Apro questo W.I.P. con l’intenzione di caricare la cucina digitalizzata tempo fa ( https://www.blender.it/forums/topic/cucina-photo-to-render/ ) su UE per potermi muovere al suo interno con Oculus DK2 e Gamepad !
    So che non posso caricarla cosi com’è essendo in High Poly.
    Il processo che ho in mente è di fare il retopo di ogni pezzo della cucina, un bake della resa grafica e montare tutto su UE.
    Non avendo mai fatto un qualcosa di simile ( eccetto per semplici Low Poly caricati direttamente su UE in formato FBX ), mi sembrava obbligatorio aprirne un W.I.P.
    Fatemi sapere le vostre opinioni o consigli 🙂
    Grazie a tutti !

    #491194

    andcamp
    Moderatore
    • Veterano Platino
    • ★★★★★★
    • Post sul forum 5416
    • Blender Italia Staff
    • Associato Blender Italia

    gli elettrodomestici (forno microonde etc.) a parte le manopole in rilievo il resto sono solo parallelepipedi con textures


    #491196

    michele vinci
    Partecipante
    • Blenderista
    • Post sul forum 39

    Grazie andcamp !
    Molte parti della cucina sono divise in vari oggetti ! E’ necessario unire le mesh e di conseguenza le UV map in un unico oggetto per farne il bake ? Sai dove potrei trovare qualche tutorial/videotutorial sul bake di più oggetti su cycles ?
    Di pomeriggio inizierò a fare qualche prova su qualche oggetto !

     

    #491197

    andcamp
    Moderatore
    • Veterano Platino
    • ★★★★★★
    • Post sul forum 5416
    • Blender Italia Staff
    • Associato Blender Italia
    #491213

    michele vinci
    Partecipante
    • Blenderista
    • Post sul forum 39

    Grazie andcamp ! Utilissimo il link di blenderartists !
    I test sono andati malissimo 🙂
    Ho provato a fare il bake combined del mobile e della pentola ma la texture diventa tutta nera ! ( Non capisco dov’è il problema ).
    Il bake delle normali riesco ad averlo senza problemi ma quando provo a montarlo sul modello low poly non combaciando le UV, mi da risultati non voluti. ( qui ho pensato di poter risolvere con i mark seems ).

     

    #491215

    michele vinci
    Partecipante
    • Blenderista
    • Post sul forum 39

    Ho provato con un altro vecchio progetto ( una spada laser ) !
    Fatto il retopo, unwrappato il low poly, e fatto partire il bake con l’opzione “selected to active” selezionando prima l’High Poly e poi il Low Poly !
    Qualcosa l’ha bakeata ma la maggior parte della texture rimane nera !
    Forse sto sbagliando con il retopo a questo punto. La mesh del low poly deve essere proprio aderente all’High Poly ? Perchè il pezzo che è riuscito a bakeare è proprio il pezzo più aderente !

    #491241

    michele vinci
    Partecipante
    • Blenderista
    • Post sul forum 39

    Sto uscendo di testa ! Non capisco proprio perchè la texture mi appare nera !
    La procedura che sto seguendo è la seguente:
    1. Seleziono l’oggetto; 2.creo una nuova texture ( 1024×1024 ); 3.faccio l’unwrap ( tramite smart UV project ); 4.in ogni materiale dell’oggetto aggiungo il nodo image texture con selezionata la texture creata nello step 2; 5. faccio partire il bake combined con il nodo image texture selezionato !
    Risultato: sempre la solita texture nera.

    #491243

    michele vinci
    Partecipante
    • Blenderista
    • Post sul forum 39

    Con la stessa precisa ed identica procedura in un file nuovo fa il suo dovere:

    #491244

    Cristina Ducci
    Moderatore
    • Blender Italia Staff
    • Associato Blender Italia
    • Professionista accreditato

    Ciao Michele. Se usi l’opzione “Select to Active”, a volte devi regolare il “Ray Distance”.

    Per quanto riguarda la seconda opzione ti faccio una domanda stupida: è illuminata la scena?


    BMI Blender Magazine Italia
    #491245

    michele vinci
    Partecipante
    • Blenderista
    • Post sul forum 39

    Ho provato ad importare alcuni oggetti della cucina in un file nuovo e l’errore non persiste ! Stranissimo :/
    Ora penso di poter andare avanti !

     

    #491246

    michele vinci
    Partecipante
    • Blenderista
    • Post sul forum 39

    Grazie Cristina ! 🙂 Si è illluminata ! Non capisco proprio cosa possa esserci che crei le texture nere nel file della cucina ! Ripeto spostando gli oggetti compresi di materiali in un’altro file nuovo non ho questo problema e riesco a fare i bake !

    #491299

    michele vinci
    Partecipante
    • Blenderista
    • Post sul forum 39

    Ho fatto il retopo low poly di alcune parti della cucina portando ad esempio il mobile della cucina da 3000 a 800 facce circa ! L’ho importato con successo su UE !

    Ora mi rimangono 2 dubbi !
    Punto 1: Come posso fare un conteggio delle facce “massime” che un pc riesce a processare in real-time ?
    Punto 2: Sto avendo seri dubbi sul poter “importare” la resa grafica dei materiali creati su cycles nell’UE ! Penso di dover rifare i materiali su UE.

Stai vedendo 12 articoli - dal 1 a 12 (di 12 totali)

Devi essere loggato per rispondere a questa discussione.