Stai visualizzando 6 post - dal 1 a 6 (di 6 totali)
  • Autore
    Post
  • hunter81
    Partecipante
    • Blenderista
    • Post sul Forum 106
    @hunter81
    #865663

    CIao a tutti
    Allora, mi stavo cimentando con un tutorial su un oggetto a scomparsa (io ho usato una scritta)
    In linea di massima mi è riuscito, (il video non è il rendering definitivo, tuttavia è capitato anche dopo aver creato il filmato)

    Durante la discesa, il cubo (grigio di default) diventa dello stesso colore della scritta, nonostante NON CI SIANO AZIONI DEL GENERE durante l’inserimento dei keyframe.
    In pratica il cubo esce verticalmente facendo materializzare la scritta che nasconde al suo interno.
    Il mio dubbio è capire PERCHE’ il cubo cambia colore.
    Grazie

     

    Tutorial_Scritta_scomparsa

     

    1_0_Tutorial_Scritta_a_Scomparsa

    Il tutorial di riferimento è questo

     

    Davide
    Partecipante
    @loscalzo-davidegmail-com
    #865671

    Ciao, Davvero strano, comunque questo effetto lo puoi fare anche tutto con i materiali senza usare il cubo, animando per esempio le texture coordinate impostate in modalità window (per esempio con separate xyz prendi solo la coordinata y e poi lo usi come mix tra trasparenza e colore e imposti un keyframe su coordinata y), mai fatto io, ma su questo sono sicuro (ma un pochino più complesso perché devi conoscere un pò i nodi). Per capire perché il cubo compare e poi scompare a intermittenza bisognerebbe guardare il materiale, ma comunque è molto strano. Verifica che non siano impostati altri keyframes nel cubo diversi dalla location, per esempio prova a verificare intanto se si presenta sempre allo stesso numero di frame, se si bloccati li e vai a vedere nello shader del cubo i valori che assume

    hunter81
    Partecipante
    • Blenderista
    • Post sul Forum 106
    @hunter81
    #865683

    Allora se ho ben capito, dovevo controllare i SINGOLI KEYFRAME del cubo per capire se i nodes (che non ho mai messo), ne alteravano la colorazione.

    Ricapitolando, il cubo cambia colore nei seguenti keyframe:
    1) keyframe 20-25 cambio colore cubo -> nessuna variazione sui nodes
    2) keyframe 29
    3) Keyframe 32

    nei Nodes però non c’è alcuna variazione

    1_0_Luci_Neon_keyframe

    Pasticciamusica
    Partecipante
    @pasticciamusica
    #865684

    Allora ho capito una cosa, non è il cubo che ha problemi ma il boolean della scritta, comunque ho trovato la soluzione, nei modificatori metti prima il boolean e poi il bevel e funzionerà

    Davide
    Partecipante
    @loscalzo-davidegmail-com
    #865691

    Io non ho visto il tutorial, allora è come dice @Pasticciamusica

    hunter81
    Partecipante
    • Blenderista
    • Post sul Forum 106
    @hunter81
    #865709

    Perdonate la nabbaggine. Adesso funziona.
    Grazie per la dritta.

    2_0_Scritta_scomparsa_Mod_Invertiti

Stai visualizzando 6 post - dal 1 a 6 (di 6 totali)
  • Devi essere connesso per rispondere a questo topic.