Blender Italia forums Supporto Utenti Supporto Materiali e texture Texture che non si applicano! (esercitazione)

Status della richiesta: Risolto

Taggato: ,

Stai visualizzando 8 post - dal 1 a 8 (di 8 totali)
  • Autore
    Post
  • Kiactus
    Partecipante
    • Blenderista
    • Post sul Forum 5
    #779561
    Ragazzi scusate la possibile domanda sciocca… Provo a mettere delle texture per l’esercitazione ma il materiale viene visualizzato correttamente solo nei plane. Negli altri oggetti non riesco… sbaglio qualche impostazione? :S

    Ho usato wrangler per creare tutti i nodi, texture scaricate dal sito cc0

    Provando in con oggetti appena generati funziona però…
    Ho provato a ricalcolare le normali, scalare ma nulla. Non ne vuole sapere di applicare il materiale alla faccia del muro ne alla scrivania realizzata durante l’esercitazione. Al soffitto e al pavimento invece tutto perfetto…
    NN81
    Partecipante
    #779578

    ciao, cerca di essere più specifico quando fai una richiesta, tu sai di cosa parli ma gli altri non è sempre facile andare incontro, se alleghi screenshot della viewport, materiali ecc è sempre meglio, se alleghi il file blend e condividi il link meglio ancora.

    solitamente una  mesh assegni un materiale poi se stai usando le uvmap come riferimento per le texture (si presume che hai unwrappato le mesh) il risultato dovrebbe essere garantito (luci in scena hdri incluse ovviamente o materiale flatshaded)

    Kiactus
    Partecipante
    • Blenderista
    • Post sul Forum 5
    #779603

    Ok scusami!
    Sono all’inizio, ho messo 2 materiali: Parquet e Piastrelle Cucina.
    Sul solaio e pavimento funzionano. Sulle mura del monolocale (è l’esercizio che hanno lasciato per il corso!) no.
    Sono ancora alle prime armi, ma devo unwrappare tutto? :S
    Vorrei solo mettere una texture piana su una faccia singola.
    Allego il file! Monolocale test
    Grazie 😀

    NN81
    Partecipante
    #779608

    Sono ancora alle prime armi, ma devo unwrappare tutto? :S

    non neccessariamente, ma in linea di massima si, è la soluzione più diffusa e adottata per millemila buone ragioni

    ora non posso dare un occhaita approfondita al tuo file nello specifico ma le cose che ti ho detto prima sono universalmente valide, devi assicurarti di assegnare il o i materiale/i alla mesh, devi assicurarti di aver unwrappato quel che vuoi texturizzare per proiettare correttamente quell’immagine su una determinata superficie

    Kiactus
    Partecipante
    • Blenderista
    • Post sul Forum 5
    #779610

    Grazie!!! Riproverò in questi giorni 😀

     

    NN81
    Partecipante
    #779616

    @Kiacktus

    comunque si, sembra che il problema sia che non hai unwrappato, ho fatto una prova volante con il mio wallpaper che non avevo altre immagini a disposizione (sono fresco di un format totale del PC)

    prossima volta che uppi un file ricordati di spuntare anche questa opzione che ti ho evidenziato così chi lo testa si ritrova tutto packato nel blend file

    Kiactus
    Partecipante
    • Blenderista
    • Post sul Forum 5
    #779703

    E’ veroooo scusa non ci ho pensato proprio :S
    Va bene ti ringrazio! E’ sicuramente quello l’errore. Ora ci provo!
    Grazie! 😀

    Kiactus
    Partecipante
    • Blenderista
    • Post sul Forum 5
    #779705

    Perfetto!!! Grazie di tutto! Ancora devo imparare un sacco! Grazie infinite 😀

Stai visualizzando 8 post - dal 1 a 8 (di 8 totali)
  • Devi essere connesso per rispondere a questo topic.