Blender Italia Forum Supporto Utenti Supporto Materiali e texture Texture rotta quando esporto e importo la mesh fbx

Stai visualizzando 6 post - dal 1 a 6 (di 6 totali)
  • Autore
    Post
  • Buscio-8
    Partecipante
    • Blenderista
    • Post sul Forum 22
    @albertobuscicchio
    #866013

    Salve a tutti!

    Ho creato un modello low poly di un astronauta, ora vorrei capire come esportarlo correttamente per renderlo disponibile sul web. L’ho esportato come .fbx ma, quando lo re-importo in Blender la texture appare rotta, semi-trasparente, con il motore Eevee. Se passo a Cycles invece è tutto a posto, potete vedere la differenza negli allegati.

    La procedura che ho usato per esportare è la seguente:

    File > export > .fbx

    Path mode: copy

    Attivato l’icona “Embed textures”

    Limit to: selected objects

    In Armature deseleziono “Add leaf bones”

    Infine Export FBX

    ——————————————————–

    Qualcuno saprebbe dirmi cosa faccio di sbagliato, e perché il problema è solo con Eevee?

    Poi ci sarebbe anche questo fatto che alcune ossa dell’armatura diventano giganti quando importo il modello e non so perché, ma quello non è un grosso problema.

    Grazie mille a chi potrà/vorrà aiutarmi!

    Alberto

    Pasticciamusica
    Partecipante
    @pasticciamusica
    #866018

    Controlla nel materiale se si è attivato alpha blend, mettilo in opaque

    Buscio-8
    Partecipante
    • Blenderista
    • Post sul Forum 22
    @albertobuscicchio
    #866022

    Mmh immagino tu ti riferisca a questo, e sì, sembra impostato su opaco…

    Buscio-8
    Partecipante
    • Blenderista
    • Post sul Forum 22
    @albertobuscicchio
    #866025

    No okay scherzavo, avevi ragione!

    Io stavo guardando nel file del modello originale ed era okay, mentre aprendo un nuovo file e importando l’FBX il blend mode diventava alpha blend…ma perché? C’è un modo per evitare che accada?

    Grazie mille per avermi risolto questo problema!!

    Pasticciamusica
    Partecipante
    @pasticciamusica
    #866028

    Strano, anche a me quando importo qualcosa me lo fa cosi, uguale al tuo, devo sempre andare nei vari materiali e risistemarli, ho fatto varie prove anche ora, ma sono sempre i materiali,  non so come aiutarti.

    Pasticciamusica
    Partecipante
    @pasticciamusica
    #866029

    Non so cosa possa essere, cambia sempre in alpha, tutte le volte

     

Stai visualizzando 6 post - dal 1 a 6 (di 6 totali)
  • Devi essere connesso per rispondere a questo topic.