Blender Italia forums Supporto Utenti Supporto Materiali e texture texture strana con codice a barre?

Status della richiesta: Risolto
Stai visualizzando 13 post - dal 1 a 13 (di 13 totali)
  • Autore
    Post
  • Vidart
    Partecipante
    • Blenderista
    • Post sul Forum 94
    #583812

    Buongiorno a tutti!
    non capisco come mai compaiono queste righe strane tipo bar code sulla mia mesh. c’è qualcosa che sbaglio, ma cosa?

    Niivaedar Leynhar
    Membro
    • Blenderista
    • Post sul Forum 106
    #583814

    Forse qualcuno con più esperienza può intuire cosa sia successo, ma penso che occorra qualche informazione in più per capirlo, tipo il materiale usato o la conformazione della mesh… spesso facce nere possono derivare da sovrapposizione di facce e/o normali invertite, però per avere un numero così fitto e articolato di linee nere dovresti avere davvero un putiferio di vertici in quella faccia, il che mi sembra difficile dato la semplicità di quella geometria. Nel materiale hai messo texture di qualche tipo?

     

    NN81
    Partecipante
    #583815

    così a occhio sembrerebbe un qualche errore di geometrie, hai già verificato il remove doubles? applicata la scala rotazione con ctrl+a?


    Jack Of All Trades
    #583817

    Ciao, c’è applicata una texture alla tua immagine?


    BMI Blender Magazine Italia

    Formazione

    Canale YouTube Tutorials

    Vidart
    Partecipante
    • Blenderista
    • Post sul Forum 94
    #583818

    facendo ctrl+a si è risolto! Grazie!

    Vidart
    Partecipante
    • Blenderista
    • Post sul Forum 94
    #583819

    no comunque non c’era applicata nessuna texture

    Vidart
    Partecipante
    • Blenderista
    • Post sul Forum 94
    #583824

    no scherzavo, Cioè nel senso che mi sono accorta adesso che si è risolto poco… c’è sempre una sorta di sfumatura nera nella mesh. Tra l’altro, ho notato solo adesso che questo problema c’è sia in questo che in un altro oggetto, ma non so da cosa dipenda

    NN81
    Partecipante
    #583825

    ctrl+a a tutte le mesh


    Jack Of All Trades
    Fangetto
    Membro
    • Veterano
    • ★★
    • Post sul Forum 654
    #583829

    Hai Ricalcolato le Normali? slezioni tutte le facce dell’oggeto poi dal menu  Shading/UVs – Normals – Recalculate

    Econtrollato di non avere vertici doppi? W – Remove Doubles


    Don’t Feed The Trool
    Vidart
    Partecipante
    • Blenderista
    • Post sul Forum 94
    #583852

    si si l’ho già fatto le avevo ricacolate, ma niente.. rimane questa specie di sfumatura nera.
    ma in che senso ctrl+a a tutte le mesh? gli oggetti che hanno questa problematica sono solo due e sono staccati e separati tra loro, non fanno parte dello stesso oggetto

    NN81
    Partecipante
    #583853

    allora dovrebbe essere sufficiente che la applichi a quei due oggetti anche se è buona prassi (soprattutto con modificatori in giro) di applicarla sempre ovunque. ora mi viene inmente anche un altra cosa, che fonti di luce stai usando per la scena? se non ricordo male usando hemi/area dovresti assicurarti di non scalarle mai su scena, in caso l’avessi fatto conviene rimpiazzarle ex.novo


    Jack Of All Trades
    Fangetto
    Membro
    • Veterano
    • ★★
    • Post sul Forum 654
    #583856

    Io continuo a pensare a dei problemi di normali/geometria, proverei a cancellare il fianco del mobile del lavello (compreso il loop finale del piano e dei fianchi) e lo ricostruirei per vedere se il problema rimane, può capitare che si creino dei loop/vertici involontariamente e poi non si riesce a eliminarli nemmeno con le bombe a mano


    Don’t Feed The Trool
    Matteo B SpiralForce
    Membro
    • Blenderista
    • Post sul Forum 15
    #585789

    esatto cara, quelli sono i classici segnali di una geometria non corretta, se hai utilizzato il “remove dubles” può darsi che tu abbia cancellato qualcosa piuttosto che unito qualche vertice che non avresti dovuto con il tasto F, ti conviene entrare in wareframe con la Z e scorrere con TAB+SHIFT la visione di vertici, edge e face per essere sicura che sia tutto a posto, magari selezionando vertici, linee e facce adiacenti all’area difettosa.

    Altrimenti potrebbe essere un problema di ombre, anche se non sembra dalla foto, può essere che l’oggetto in questione abbia le ombre in modalità smooth e non flat, comunque è sicuro un problema da poco è sufficiente che lo trovi, non ti arrendere

Stai visualizzando 13 post - dal 1 a 13 (di 13 totali)
  • Devi essere connesso per rispondere a questo topic.