Status della richiesta: Non risolto
Stai vedendo 8 articoli - dal 1 a 8 (di 8 totali)
  • Autore
    Articoli
  • #535801
    WildArtWorks
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 885

    Ciao a tutti. Mi trovo di fronte ad un problema che non so se si può risolvere o dovrò rifare il render di tutti i frame dell’animazione.

    Stavo facendo l’animazione del TETRIS. Avevo aperto una richiesta di supporto sulla lentezza del rendering. Dunque la soluzione migliore sembrava quella di renderizzare i livelli in modo separato, con il fondo trasparente. Avevo spostato lo SFONDO (che rimane sempre fisso), su un secondo livello e ho renderizzato solo lo sfondo. Nel primo livello, ho lasciato la luce e solo i pezzi del tetris che scendevano in verticale. Poi ho renderizzato in formato PNG, tutti i FRAME circa 1300, impostando nella sezione RENDER, la TRASPARENZA. L’ho fatto in vari giorni separati. Ora, attraverso il Video Sequence Editor, ho caricato tutte le immagini dello SFONDO e dei pezzi del TETRIS. Chiaramente su un livello vanno le sequenze dei pezzi che cadono, sul secondo livello solo l’immagine fissa dello sfondo come da immagini allegate.

    Mi ha preso un colpo! Perché praticamente è come se la sequenza dei pezzi del tetris, non fosse trasparente. C’è quel NERO fisso dietro tutti i pezzi che oscura il fondo. Non capisco come possa essere accaduto, se ho flaggato proprio su trasparente nella sezione render. Ho tentato di applicare degli effetti che solitamente funzionano nelle sovrapposizioni di immagini tipo: MULTIPLY, SCREEN, OVERDROP, GAMMACROSS, ma l’unica cosa che sono riuscito a fare è abbassare l’opacità dei pezzi del tetris (vedasi seconda immagine). Ma fa schifo.

    Sapreste darmi un consiglio?

    Grazie


    3D Volenteroso
    #535917
    andcamp
    Moderatore
    • Veterano Platino
    • ★★★★★★
    • Post sul Forum 6223
    • Associato Blender Italia
    • Moderatore Forum

    Ciao, ma guardando su computer una singola immagine png c’è la trasparenza?


    #535931
    WildArtWorks
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 885

    OHHH CACCHIO!!!! Mi vien da piangere! Ho notato ora che le singole immagini dei FRAME dei pezzi hanno estensione .JPG Ma perché ho fatto questo sbaglio? devo rifare i 1300 frame da capo 🙁


    3D Volenteroso
    #535932
    Fiasco Games
    Partecipante
    • Veterano Bronzo
    • ★★★
    • Post sul Forum 1195
    • Associato Blender Italia

    ahi….. ecco  il perchè della trasparenza che andava a farsi benedire.. guarda il lato positivo, con quello che ti costerà ri-renderizzare i 1300 dubito sbaglierai di nuovo in futuro ^^


    Mater artium necessitas..
    #535952
    riky70
    Partecipante
    • Veterano Bronzo
    • ★★★
    • Post sul Forum 2059

    infatti… il JPG non supporta il canale Alpha… capita tranquillo… non sai quante volte…

    #535953
    riky70
    Partecipante
    • Veterano Bronzo
    • ★★★
    • Post sul Forum 2059

    o prendi i singoli frame e con gimp li “trasparentizzi” e li salvi in PNG uno ad uno oppure devi rirenderizzare…

     

    #535955
    TheKne
    Partecipante
    • Blenderista
    • Post sul Forum 18

    Ciao ti do due consigli:

    1) usi una renderfarm e con meno di 20 euro impostando GPU render (rebusfarm lo fa) te la cavi

    2) imposti un materiale bianco emitter a tutti gli oggetti in scena visibili (puoi farlo impostando il materiale globale) e ti ricavi  rirenderizzando una sequenza (di canali alpha) che potrai usare nel compositing. per fare questa cosa puoi renderizzare a bassisimo sampling e in poco tempo recuperi il lavoro.

    Cari chi i tuoi 1300 fotogrammi jpg carichi i tuoi alpha (jpg o png) li combini nel compositing, come output dai PNG con trasparenza miraccomando e hai risolto!!

     

     

    #535988
    WildArtWorks
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 885

    Grazie delle info. Sto rifacendo il render… Piano piano. Questo sembra trasparente ahahahaha


    3D Volenteroso
Stai vedendo 8 articoli - dal 1 a 8 (di 8 totali)
  • Devi essere loggato per rispondere a questa discussione.