Blender Italia | ArtWork | Work in Progress | VSA – Voglio Svegliare l\'Aurora

Stai vedendo 25 articoli - dal 1 a 25 (di 49 totali)
  • Autore
    Articoli
  • #577402

    BottyE
    Partecipante
    • Blenderista
    • Post sul Forum 57

    Ciao!

    Sono un pazzo che, con mia moglie, s’è tuffato in una avventura pazza, animare la storia di un intero libro!

    C’è l’ok di Autrice [Irene Biasi] ed Editore [Il Segno dei Gabrielli].

    Ora necessito di vestire il personaggio ma l’abito, importato da Make Human rimane “trasparente”.
    Da cosa può dipendere?
    Il personaggio è Linkato_proxy, il vestito no, può essere questo?

    [A sinistra il mio personaggio, a destra quello manichino da Make Human].

    Grazie.

    E-

    #577429

    pix di chito
    Moderatore
    • Associato Blender Italia
    • Professionista accreditato
    • Moderatore Forum

    premesso che non sono sicuro di aver capito il problema, controlla che abito o vestito non siano impostati come oggetto xray o visibili solo in wire (properties window, object tab)


    architetto freelance – CG artist – art director & 3d artist presso VidaSystems
    #577478

    BottyE
    Partecipante
    • Blenderista
    • Post sul Forum 57

    Ottimo, grazie!

    Ora intendo adattare gli abiti al corpo, ma come li lego poi ai movimenti del modello
    sì che se Alba, il personaggio, muove un braccio il vestito segua il movimento?

    Grazie!

    E-

    #577480

    pix di chito
    Moderatore
    • Associato Blender Italia
    • Professionista accreditato
    • Moderatore Forum

    io ti consiglio questo:

    • rimuovi la geometria del corpo nascosta dai vestiti (così ti eviti compenetrazioni strambe e allo stesso tempi rimuovi geometria ormai inutile)
    • unisci corpo e vestiti (ctrl+j)
    • applichi l’armatura al tutto (solitamente è sufficiente parent with automatic weights)

    architetto freelance – CG artist – art director & 3d artist presso VidaSystems
    #577481

    BottyE
    Partecipante
    • Blenderista
    • Post sul Forum 57

    Grazie, pix di chito,

    più avanti, Alba però deve restare in costume, diciamo, come posso poi gestire le scene in cui si toglie gli abiti per tuffarsi da una cascata?

     

    Tra l’altro non riesco a utilizzare il Proportional Editing su dei punti, in quanto mi sposta l’intero abito correlato.

    Da qualche parte mi pare vi fosse un “peso” da impostare per la deformazione, … sarà quello?
    Non so più dove sia, comunque.

    Grazie

    E-

    #577482

    pix di chito
    Moderatore
    • Associato Blender Italia
    • Professionista accreditato
    • Moderatore Forum

    per la seconda scena puoi usare un secondo modello con la geometria completa

    per il problema del proportional editing o lo disattivi (o) o ne modifichi il raggio (rotella del mouse)


    architetto freelance – CG artist – art director & 3d artist presso VidaSystems
    #577483

    BottyE
    Partecipante
    • Blenderista
    • Post sul Forum 57

    Grazie, seguirò il tuo consiglio, per il modello..

    Per il PropEdit, nada, sbaglio qualcosa…

    Con la rotella del mouse mi fa lo zoom, se sposto con PE attivo mi sposta tutto l’oggetto, se no, non c’è PE 😉

    Grazie

    E-

    #577485

    Fangetto
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 661
    • Associato Blender Italia

    Ciao, complimenti per l’iniziativa, ti auguro di riuscire a portare a termine il tuo progetto!
    Per il PE la rotella del mouse la devi ruotare mentre sposti non prima, probabilmente è questo il problema.
    Ti consiglio di farti un corso sull’animazione ne trovi diversi online a poco (10/15€), andare a intuito su un progetto esteso non la trovo una buona idea.


    Don’t Feed The Trool
    #577486

    BottyE
    Partecipante
    • Blenderista
    • Post sul Forum 57

    Grazie, Fangetto!

    Il problema è che appena attivo il PE, se seleziono un punto e tento di spostarlo, mi sposta tutto [anche il non selezionato]!

    Non so se sia qualcosa di impostato da Make Human…
    Con il cubo standard, ad esempio, mi funzia correttamente !!! ?????  Boooh?

    Ok, vedrò anche per il corso, anche se avevo già sperimentato per altre animazioni…
    tutto serve!

    Grazie.

    E-

    #577487

    Fangetto
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 661
    • Associato Blender Italia

    Non sè se MakeHuman fa qualcosa di strano (non lo utilizzo quindi non so dirti) cmq trae un pò in inganno (le prime volte che si usa) prova a ruotare in avanti la rotellina del mouse mentre lo muovi (con il tasto destro premuto) dovresti vedere il cerchio che si restringe.

    Per le animazioni se sai già fare lascialo perdere il corso, ma una cosa è animare oggetti, un’altra è animare in modo credibile character con tutte le conseguenze sulle deformazioni che ci sono e soprattutto sapere come non diventarci matto…. tipo come sfruttare i constraint per semplificarti il lavoro o regolare il peso alle ossature per evitare effetti indesiderati


    Don’t Feed The Trool
    #577556

    BottyE
    Partecipante
    • Blenderista
    • Post sul Forum 57

    Ciao,

    ok, grazie, cercherò qualche corso video di animazione di personaggi, qualsiasi suggerimento è bene accetto, specie se già provato personalmente.

     

    Ho risolto con il PE, il cerchio era “”” forse””” gigantesco, e non lo si vedeva… booh, ora mi funge bene.

     

    Grazie!!!

    E-

    #752158

    BottyE
    Partecipante
    • Blenderista
    • Post sul Forum 57

    Ciao, son tornato dopo aver seguito un corso di Rigging per animare il mio personaggio principale: Alba.

    Dopo parecchio tempo riprendo il modello fatto e sob ne scopro una che mi lascia tristissimo.

    Uso Blender 2.79

    Se sono in Edit Mode tutto mi sembra ok, o per lo meno come l’ho impostato.
    Passando in OM Alba diviene cugina di un marziano allungato!

    Da cosa può dipendere?
    Come posso rimediare?


    Grazie

     

    E-

    #752192

    Fangetto
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 661
    • Associato Blender Italia

    Ciao, quasi sicuramente hai un osso in pose mode non in posizione base


    Don’t Feed The Trool
    #752204

    BottyE
    Partecipante
    • Blenderista
    • Post sul Forum 57

    Caio Grazie,

     

    se intendi l’ALT R [Rest Pose] in PM no, non è quello,
    però m’hai fatto venire in mente una Custom Properties impostata che variandone i parametri rimedia il problema anche se non fa quanto mi aspetterei.

    Non è comunque solo la Custom, sembra siano scentrati i personaggi, uno più in alto e l’altro più in basso anche se hanno le stesse dimensioni.

    Come li riallineo?

     

    Sto cercando di unire gli insegnamenti di due corsi.

    • Disegnare un corpo umano [Blenderella]
    • Armare un corpo umano per l’animazione [Humane Rigging]

    Non so se li conosci, forse rifarò parte dell’ossatura della schiena finito di applicare il secondo corso sul primo se non comprendo bene dove sbaglio.

    Grazie

    E-

    #752205

    Fangetto
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 661
    • Associato Blender Italia

    Considera che io vedo solo l’immagine che hai postato prima, mi stai parlando di personaggi e di custom ma io non ho idea a cosa tu ti riferisca.. 🙂
    Quello è un problema di posizione/scalatura delle ossa o pesi (anche le dita sono deformate).
    L’origine (sia del character che del rig) mettila alla base, (fra i piedi) che coincidano.
    Sparenta il Character dall’armatura, elimina i vertex group dal character e controlla di avere la scalatura neutra (1,1,1) sia sul character che sul rig se non lo è fixala (Ctrl+A -> scale), vai in pose mode e resetta tutte le ossa (Alt+R per le rotazioni, Alt+S per la scala e Alt+G per le posizioni) e reimparenta il tutto assegnando i pesi in automatico.
    Ricorda che una volta assegnata l’armatura e creati i pesi non si edita più ne l’Armatura ne la Mesh.


    Don’t Feed The Trool
    #752206

    BottyE
    Partecipante
    • Blenderista
    • Post sul Forum 57

    Urca, grazie!!!

    Si, scusa come personaggi intendevo le due img in EM e PM 😐
    mi son spiegato malissimo…

    Ci provo appena riesco, grazie 10000… 🙂

    #752484

    BottyE
    Partecipante
    • Blenderista
    • Post sul Forum 57

    Ciao Fangetto,ciao a tutti.

    Ho provato a fare quanto hai detto nel primo punto:

    L’origine (sia del character che del rig) mettila alla base, (fra i piedi) che coincidano.

    Ho messo a disposizione i .blend sul sito del progetto nella sezione PreProduzione:

    Prima

    http://vsa.altervista.org/Blender/Proge/Blend/VSA_00_P_S1_Alba.017.blend

    e dopo

    http://vsa.altervista.org/Blender/Proge/Blend/VSA_00_P_S1_Alba.017_riallin.blend

     

    Mi faresti un grandissimo favore se gli dessi un occhiata per vedere se ho compreso bene…
    (non vorrei partire col piede sbagliato).

    <hr />

    Ho notato anche uno strano strabismo degli occhi, ho provato a togliere l’X-Axis Mirror dall’armatura occhi, riposizionare e ripristinare, ma [ovviamente] riporta in specularità appena muovo le ossa.

    Dov’è lo sbaglio?
    (v. img).

    Grazie!

    E-

    #752487

    BottyE
    Partecipante
    • Blenderista
    • Post sul Forum 57

    L’origine (sia del character che del rig) mettila alla base, (fra i piedi) che coincidano.

    Sparenta il Character dall’armatura,
    OM
    ALT P Clear Parent

    elimina i vertex group dal character
    WP
    Properties Panel – Vertex Group [-]

    e controlla di avere la scalatura neutra (1,1,1) sia sul character che sul rig se non lo è fixala (Ctrl+A -> scale),
    CHR 1,1,1
    Arm .0479, 0.479,0.479 –> CTRL A -> Scale Arm 1,1,1

    vai in pose mode e resetta tutte le ossa (Alt+R per le rotazioni, Alt+S per la scala e Alt+G per le posizioni)
    PM
    ALT R
    ALT S
    ALT G

    Forse per il secondo file del post sopra non avevo capito ed ho spostato “a mano”.

    Ora ho fatto le fasi sopra:

    In PM però mi trovo l’armatura disallineata al corpo (CHR=Character)

    l’armatura è posizionata più in basso…

     

    3° file: http://vsa.altervista.org/Blender/Proge/Blend/VSA_00_P_S1_Alba.017__.neutr_ALT_RSG.blend

     

    Grazie

     

    E-

    #752499

    BottyE
    Partecipante
    • Blenderista
    • Post sul Forum 57

    Nel file http://vsa.altervista.org/Blender/Proge/Blend/VSA_00_P_S1_Alba.017__.neutr_ALT_RSGb.blend

    credo, e dico credo, (se puoi verificare…)
    di aver risolto il disallineamento tramite la Proprietà Personalizzata ScorriFulcro che,
    anche se qui, per ora, non funziona su tutto il corpo,
    permette di traslare il personaggio su un punto fisso come centro di rotazione/inclinazione così da agevolare le fasi di animazione.

    Ho corretto la differenza di posizione delle braccia spostandole da PM come in EM.
    Ora, anche facendo ALT G non c’è più lo spostamento delle ossa tra EM e PM.

    Rimane il problema dello strabismo.

    Grazie

    E-

    #752553

    Fangetto
    Partecipante
    • Veterano
    • ★★
    • Post sul Forum 661
    • Associato Blender Italia

    Ho dato un’occhiata al file, non so se hai utilizzato qualche addon nella creazione del rig che se resettato può dare dei risultati bizzarri, ma posso dirti che cosi non va bene.

    Il procedimento da seguire per fare un character è relativamente semplice, si crea la mesh, si crea il rig, si assegna la mesh al rig, si controllano le deformazioni e modificano i pesi dove necessario, si creano i constraint, come optional si creano le ossa personalizzate; ogni operazione fuori da questi punti è sbagliata, se qualcosa non và come dovrebbe è stato commesso un errore nelle fasi precedenti e quindi si torna indietro, non si cercano soluzioni alternative.

    Il binomio armatura – mesh deve essere PERFETTO non ci sono vie di mezzo, le origini di tutti gli oggetti assegnati all’armatura devono coincidere con l’origine dell’armatura, le ossa che deformano devono essere all’interno della mesh e posizionate sulle giunture seguendo la topologia del modello.

    Per questo modello ti consiglio di ricreare il rig da 0, e magari farti un pò di esperienza anche nell’animazione con modelli semplici sia come rig che come mesh, un buon esempio è il CubeDude di Michael Bridges di cui ti consiglio il corso (quando in offerta (circa un paio di settimane ogni mese) lo acquisti con 10/12€ Link al corso), parte dalle basi (modellazione compresa) e spiega in modo semplice (e su modelli semplici) tutto quello che bisogna sapere per iniziare ad animare, dai principi dell’animazione alle action, passando per dope sheet e graph editor.

    Esempio di CubeDude

     


    Don’t Feed The Trool
    #752555

    Davide
    Partecipante
    • Blenderista
    • Post sul Forum 256

    un altro buon tutorial sul rigging è quello di Darrin Lile … lo trovi in rete. Free. Completo (dal progetto vuoto fino all’animazione di un personaggio stile cartoon). sono 38 video se non erro. Gli ultimi 18 sono sul rigging e animazione. E’ stato anche tradotto in italiano.


    By Daddy
    #754396

    BottyE
    Partecipante
    • Blenderista
    • Post sul Forum 57

    Ciao,

    grazie a tutti dei consigli mi son fatto tutto il corso di Darril Lile, molto bello!

    N.B.: Da Giugno, ho letto che non sarà più disponibile, ergo se a qualcuna interessa è bene lo veda presto 😐

    Quello che non mi è tanto chiaro è l’utilizzo di una figura in low poly e una high poly, ovvero quando si usa una o l’altra e perchè.

    Per il LP mi vengono in mente solo scene ad una certa distanza e per l’HP i primi piani, ma …

    Comunque la figura di Alba è quella basata sugli insegnamenti del corso di Blenderella,
    Appena rieso mi rivedo bene le parti del Rigging [è stato il primo corso fatto, chissà quante cose mi son sfuggite!]

    Il secondo è quello di Humane Rigging [sempre dal sito della Blendere Foundation]
    ed a dire il vero ho importato l’armatura direttamente dal mio file del corso in Alba.

    Le “strane” ossa della schiena servono per spostare il fulcro del personaggio nella parte del busto desiderata per una più facile gestione delle animazioni.

     

    Inizierò col togliere tutti i pesi che eventualmente fossero residui del modello originale.

    Quali sono le fasi da effettuare per essere sicuro di aver tolto tutto delle precedenti immpostazioni?

     

    Grazie ancora.

     

    #754411

    Harvester
    Moderatore
    • Veterano Bronzo
    • ★★★
    • Post sul Forum 2905
    • Associato Blender Italia
    • Moderatore Forum

    Un modello in bassa risoluzione si usa solitamente per ottenere un’animazione più fluida rispetto ad un modello in alta risoluzione, usato solitamente in fase di rendering. Ma si possono usare entrambi per ricavare le mappe dettagliate dal modello in alta risoluzione per poi applicarle a quello in bassa risoluzione mantenedolo leggero ma al contempo “apparentemente” dettagliato. Dipende.

    #754646

    BottyE
    Partecipante
    • Blenderista
    • Post sul Forum 57

    Grazie a tutti,

    Sono riuscito a rimettere un po’ tutto in ordine, Ossatura e Figura
    con origine alla base tra i piedi e Occhi con origine tra i due occhi
    (dovrebbe essere corretta così per gli occhi, o sbaglio?

    Ora stavo impostando la retopologia del personaggio per ridurrne le facce e quindi il “peso”.

    Sto sbagliando qualcosa però nell’uso della GP (Grease Pencil).

    Mentre nel corso di Darrin Lile è possibile seguire le linee del volto in superficie e queste restano visibili,
    quando disegno le linee, appena tracciate, scompaiono e sono solo più visibili in WireFrame Z ma con salti deformanti.

    In immagine cosa succede con la GP sulla superficie.

    #754659

    BottyE
    Partecipante
    • Blenderista
    • Post sul Forum 57

    Scusate, aggiungo il collegamento al file, sul sito del progetto VSA, che sto utilizzando ora:

    http://vsa.altervista.org/Blender/Proge/Blend/VSA_00_P_S1_Alba.017_05a_PP_01a.blend

    Spero possiate aiutarmi a risolvere il problema della GP che appena disegnata sparisce.

    Grazie
    E-

Stai vedendo 25 articoli - dal 1 a 25 (di 49 totali)

Devi essere loggato per rispondere a questa discussione.